USB Audio Device (FreeRTOS) demo on CY8CPROTO-062-4343W kit

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
ravo
Level 5
Level 5
10 likes received 5 comments on blog 5 solutions authored

Dears,

I am reopening old problem described in https://community.infineon.com/t5/PSoC-6/CY8CPROTO-062-4343W-USB-Audio-Device-FreeRTOS-demo/m-p/3540...

I have successfully compiled and programmed this demo, but after connecting USB cable to second connector J10 (to act as USB device). Windows 10 is unable to recognise the device. Error message "A request for the USB device descriptor failed."

I tried to change priorities in usb_comm.c (as described in old thread). But it does not help me.

Does anyone have a working demo on PROTO kit ?

Could any one help me ? What could be wrong.... 

Regards

Radim

 

0 Likes
1 Solution
Aashita_R
Moderator
Moderator
Moderator
50 likes received 100 solutions authored 250 replies posted

Hi @ravo ,

Apologies for the delay in the response for the older thread : CY8CPROTO-062-4343W - USB Audio Device (FreeRTOS) demo . I tried checking the project which you have attached in the old thread, where you mentioned that USB device is not getting enumerated and in case when you unplug the PMOD I2S2 module the "PSoC 6 USB Audio Device" is recognised by Windows 10 system correctly. The project works fine at our end. Can you please let us know a little more detail about your hardware connection? If possible, you can also share the image showing the connection of PMOD I2S2 over CY8CPROTO-062-4343W.

Can you try doing "Attach to running target" and share the results with us?

Are there any function calls or any of the init() functions that are failing? Is your project getting stuck at Pdm_PCM_Init() function which could be a possibility?

Answering these questions will help us eliminate the different possibilities what could be going wrong at your end. Please feel free to add any details from your end here.

Best Regards,

Aashita

View solution in original post

0 Likes
3 Replies
Aashita_R
Moderator
Moderator
Moderator
50 likes received 100 solutions authored 250 replies posted

Hi @ravo ,

Apologies for the delay in the response for the older thread : CY8CPROTO-062-4343W - USB Audio Device (FreeRTOS) demo . I tried checking the project which you have attached in the old thread, where you mentioned that USB device is not getting enumerated and in case when you unplug the PMOD I2S2 module the "PSoC 6 USB Audio Device" is recognised by Windows 10 system correctly. The project works fine at our end. Can you please let us know a little more detail about your hardware connection? If possible, you can also share the image showing the connection of PMOD I2S2 over CY8CPROTO-062-4343W.

Can you try doing "Attach to running target" and share the results with us?

Are there any function calls or any of the init() functions that are failing? Is your project getting stuck at Pdm_PCM_Init() function which could be a possibility?

Answering these questions will help us eliminate the different possibilities what could be going wrong at your end. Please feel free to add any details from your end here.

Best Regards,

Aashita

0 Likes
ravo
Level 5
Level 5
10 likes received 5 comments on blog 5 solutions authored

Dear Aashita,

thanks for update. Here is photo of connection between CY8CPROTO kit and PmodI2S2 via dual-line header. Jumper JP1 is in SLV (slave) position. I did not do any special modification in code which I post earlier.

ravo_0-1663849295669.png

Rudolfo send me updated code. I am going to check this.

Can we close this thread and continue in previous one? 

Best Regards

Radim

0 Likes
Aashita_R
Moderator
Moderator
Moderator
50 likes received 100 solutions authored 250 replies posted

Hi @ravo ,

Thank you for your response. Yes! We can continue our discussion on the older thread.

Best Regards,

Aashita