UART smartcard mode echo

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
PSOC6_dev
Level 4
Level 4
10 questions asked 25 sign-ins 25 replies posted

Hi all,

I've a little question about the way UART works on PSOC6.

My project is on ModusToolBox and I use only low level API for UART (smartcard mode) (Cy_SCB_UART_Put() /  Cy_SCB_UART_Get()).

Each time i send a byte, i have the echo and need to read this bytes to empty rx fifo. 

Is it normal ? is it possible to avoid this ?

 

Thank you for your support,

Regards

0 Likes
6 Replies
wisc_ece353
Level 3
Level 3
10 replies posted First question asked 10 sign-ins

I do not think you should be getting an echo on the Rx FIFO when you use the Cy_SCB_UART_Put() API.

This could be a good starting point for UART low level APIs - https://github.com/Infineon/Code-Examples-for-the-ModusToolbox-PSoC-6-SDK/blob/mt1.1/CE219656_PSoC6_...

Can you try this out and let us know if it works? Please attach your project if possible so that we can have a look.

0 Likes

Hi, Thank you for your response,

It's not the same usage. I use uart as smartcard mode (rx/tx on the same line)

Regards,

0 Likes
PSOC6_dev
Level 4
Level 4
10 questions asked 25 sign-ins 25 replies posted

Anyone experienced UART smartcard mode ?

 

0 Likes
PSOC6_dev
Level 4
Level 4
10 questions asked 25 sign-ins 25 replies posted

Infineon team ?

0 Likes
PSOC6_dev
Level 4
Level 4
10 questions asked 25 sign-ins 25 replies posted

Hello ?😞

0 Likes
PSOC6_dev
Level 4
Level 4
10 questions asked 25 sign-ins 25 replies posted

1 month without any reaction, should I flag it as a non-solution ? 🙂

0 Likes