Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
FeCh_4628961
Level 1
Level 1

Hi all!

Trying to figure this error I get when I program the (CM0p) :

"There was an error while programming the device: PSoC Programmer reported error (100 - EraseAll API returned: Error code 0x76AFF110: Unknown SROM status code)"

I am programming the Psoc63 CY8C6347FMI-BLD53 using the MiniProg4 on Psoc Creator 4.2.

Does anyone have suggestion as to what could cause this error?

Thank you in advance!

Felix

0 Likes
1 Solution
Rakshith
Moderator
Moderator
Moderator
250 likes received 1000 replies posted 750 replies posted

Hi fech_4628961​,

Please provide details regarding your setup which will help us debug your issue.

Can you please check if -

1. the schematic meets the hardware design guidelines. Please refer to the PSoC 6 Hardware Design Considerations and PSoC 6 MCU: CY8C63x6, CY8C63x7 Datasheet

2. all the Programmer Parameters and the Programmer Characteristics of PSoC Programmer are correct

3. the connections to the device from the MiniProg 4 is correct and the cable is short

Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
1 Reply
Rakshith
Moderator
Moderator
Moderator
250 likes received 1000 replies posted 750 replies posted

Hi fech_4628961​,

Please provide details regarding your setup which will help us debug your issue.

Can you please check if -

1. the schematic meets the hardware design guidelines. Please refer to the PSoC 6 Hardware Design Considerations and PSoC 6 MCU: CY8C63x6, CY8C63x7 Datasheet

2. all the Programmer Parameters and the Programmer Characteristics of PSoC Programmer are correct

3. the connections to the device from the MiniProg 4 is correct and the cable is short

Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B
0 Likes