Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
Anonymous
Not applicable

So, pretty much the problem is explained in the title.

I have placed in the schematic the ADC with 4 first inputs connected to Analog input pins and the rest are connected to the internal bandgap reference.

My project does not compile and the error I am getting is: "vinPlus_0" requires connection when it is visible. Same for channels 1,2 and 3.

Any suggestions?

0 Likes
1 Solution

Could you show the capture of topdesign?

I checked again the original project is built finely on my side. Attached here for your reference.

View solution in original post

0 Likes
3 Replies
ShipingW_81
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 250 replies posted

I don't see any error while building the attached project. The analog routing is fine.

However, there is a warning "Bonded pin(s) "P10[4], P10[5], P10[6], P9[7]" are not used in your current design but have been connected in order to route the design.".

It means these pins are borrowed for usage of analog routing from VBGR to vplus of some channels through AMux. These pins should not be used as analog I/O any more in your design.

0 Likes
Anonymous
Not applicable

Please see attached screenshot.

I am not using any of the bonded pins but I am still getting connection errors.

0 Likes

Could you show the capture of topdesign?

I checked again the original project is built finely on my side. Attached here for your reference.

0 Likes