Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

trstc_4056926
Level 2
Level 2
First like received

CMSIS library

This thread is a year old but I am having the same problem...  I have tried adding the library as 'm' and as 'libarm_cortexM4lf_math.a' but the PSOC creator keeps complaining. I have tried relative paths as well as absolute path.

Thanks

Trampas

0 Likes
1 Solution
RodolfoGL
Employee
Employee
250 sign-ins 5 comments on KBA First comment on KBA

To gives the heads up, PSoC Creator does not support floating point natively, so you will not be able to compile a project that uses libarm_cortexM4lf_math.a as it is. There is this KBA explaining why and how to contour the problem.

https://community.cypress.com/docs/DOC-14593

To fix the problem you described, there is no need to include the "Include" folder from CMSIS in the compiler settings. The PDL already contains a folder with the CMSIS files and it is part of the path.

I would suggest you to move to ModusToolbox, our new software tool. It is Eclipsed based and cross-platform. You have more flexibility on choosing how to setup the build settings, like floating point support.

View solution in original post

0 Likes
1 Reply
RodolfoGL
Employee
Employee
250 sign-ins 5 comments on KBA First comment on KBA

To gives the heads up, PSoC Creator does not support floating point natively, so you will not be able to compile a project that uses libarm_cortexM4lf_math.a as it is. There is this KBA explaining why and how to contour the problem.

https://community.cypress.com/docs/DOC-14593

To fix the problem you described, there is no need to include the "Include" folder from CMSIS in the compiler settings. The PDL already contains a folder with the CMSIS files and it is part of the path.

I would suggest you to move to ModusToolbox, our new software tool. It is Eclipsed based and cross-platform. You have more flexibility on choosing how to setup the build settings, like floating point support.

0 Likes