Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6

AyKo_4382201
Level 2
10 replies posted 5 replies posted 5 questions asked
Level 2

I'm using psoc63 on my custom design board.I have configured ble as GAP peripheral and GATT server role and selected only cm0  core for ble operation. But after generating all the ble files, when using some api function like Cy_BLE_GAPP_StartAdvertisement it shows error stating "implecit declaration of function".

0 Likes
1 Solution
AyKo_4382201
Level 2
10 replies posted 5 replies posted 5 questions asked
Level 2

After having a look at the sample ble project the issue has been solved now, thankyou for your help.

View solution in original post

0 Likes
4 Replies
ShipingW_81
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator

Please make sure the properties option "Cores" of the "Shared Files" folder in your project is selected with the correct target core, as below capture shows -

pastedImage_0.png

0 Likes
AyKo_4382201
Level 2
10 replies posted 5 replies posted 5 questions asked
Level 2

Hi, thanks for replying.

I've selected the correct target core(in my case its cortex m0p) in properties option of the shared folder and rebuilt it but still its showing the same error.2019-10-03.png2019-10-03 (1).png

0 Likes
ShipingW_81
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator

Is there any building error after you have called these APIs regardless the error stating "implecit declaration of function"? In which file you have called the APIs?

Possible to attach your project?

0 Likes
AyKo_4382201
Level 2
10 replies posted 5 replies posted 5 questions asked
Level 2

After having a look at the sample ble project the issue has been solved now, thankyou for your help.

0 Likes
Top labels