Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

bahlemeyer
Level 1
Level 1
First reply posted First question asked Welcome!

How do I use a Pemicro Multilink Universal debug module in ModusToolbox3?  I have the GDB Pemicro server installed on my computer because I use it with NXP Kinetis Design Studio.  When I try to create a debug configuration in ModusToolbox 3 that selection is not in the list.

0 Likes
1 Solution
LeoMathews
Moderator
Moderator
Moderator
100 sign-ins 25 solutions authored 100 replies posted

Hi @bahlemeyer 

Kindly note that you won't be able to program using Multilink from ModusToolBox3.0. As a workaround, you can port your ModusToolBox project to another supported IDE like Keil uvision and then use a Pemicro Multilink Universal debug module with Keil.

Thanks and Regards,
Leo

View solution in original post

0 Likes
2 Replies
LeoMathews
Moderator
Moderator
Moderator
100 sign-ins 25 solutions authored 100 replies posted

Hi @bahlemeyer 

Kindly note that you won't be able to program using Multilink from ModusToolBox3.0. As a workaround, you can port your ModusToolBox project to another supported IDE like Keil uvision and then use a Pemicro Multilink Universal debug module with Keil.

Thanks and Regards,
Leo

0 Likes

Thanks, Leo.  Do you know the reason that it is not supported?  I see on the Pemicro site that it can be used with the DAVE IDE, but I don't think that I can use that with my CY8C6144LQI-S4F12.  Can my CY8CKIT-062S4 be used without removing the uC on that board?  What would you suggest?  The Miniprog4 or would a J-Link be better?

0 Likes