Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
ThWi_3938146
Level 1
Level 1

I have attached two intel hex files for the PSoC6 BLE Pioneer Kit.

The first leds_on.hex is built with PSoC Creator and boots as expected after reset.

The second leds_blink.hex is built outside PSoC Creator it does not boot after reset.

When I attach the debugger the PC is stuck at 0x00001F2C.

If I set the SP and PC to values stored in the vector table, leds_links works properly and I can debug without a problem.

It appears like the reset vector is never entered on boot.

Note: I am using JFlash to load the hex files.

I have inspected the vector table and everything looks fine to me.

I would like to know what I am missing.

Thanks.

0 Likes
1 Solution

You can find more information on that issue here: CY8CKIT-062-BLE Setup Only requires PDL 3.0.1

Regards,

Dheeraj

View solution in original post

0 Likes
5 Replies
MeenakshiR_71
Employee
Employee
100 likes received 50 likes received 25 likes received

Are you using the same project from the application or is it in your own project? If the latter, then can you share the project?

0 Likes
ThWi_3938146
Level 1
Level 1

It looks like I might have a hardware problem.

I swapped out my PSoC6 BLE Pioneer Kit for a new one and the PC is no longer stuck at 0x00001F2C.

What does it mean when the PC is stuck at 0x00001F2C?

Thanks.

0 Likes

I suspect this to do with older version of the kit that had *A silicon.

0 Likes

I have edited the original question to help clarify.

I did have this same problem with a PSoC Creator blink project and loading directly inside of the tool.

When I did that PSoC creator debugger showed the PC at 0x00001F2C. Swapping the hardware addressed the issue.

So I would like to know more about this *A silicon issue you have described.

But after I swapped the hardware, I still have the problem but only in the leds_blink.hex file.

Thanks for your response.

0 Likes

You can find more information on that issue here: CY8CKIT-062-BLE Setup Only requires PDL 3.0.1

Regards,

Dheeraj

0 Likes