Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
CaKu_4284131
Level 5
Level 5
50 replies posted 25 replies posted 10 likes received

When I program my CY8CKIT-062-BLE I get this warning:

Programming device 'PSoC 63 CY8C6347BZI-BLD53 (CM4)' with file 'C:\Users\carlk\Documents\PSoC Creator\PSoC 6 intro\CapSense_BLE.cydsn\CortexM4\ARM_GCC_541\Debug\CapSense_BLE.hex'.
Device ID Check
Warning: The connected PSoC6 MCU device is out of date. Please contact Cypress to get a replacement

How can I fix that? Might it have anything to do with BLE difficulties I've been having?

0 Likes
1 Solution

This warning is displayed for kits w/ PSoC6A-BLE Silicon Revision (Rev.*B) and FlashBoot build version less than 29 because in this combination of Silicon and Flashboot, the build is broken and might cause numerous issues. Request you to update to the latest revision.

You will contacted by Cypress to provide you a replacement.

Regards,

Dheeraj

View solution in original post

8 Replies
MotooTanaka
Level 9
Level 9
Distributor - Marubun (Japan)
First comment on blog Beta tester First comment on KBA
0 Likes

I'm on Kit rev *D, Board rev 13. Is that already out of date?

0 Likes
MotooTanaka
Level 9
Level 9
Distributor - Marubun (Japan)
First comment on blog Beta tester First comment on KBA

Hi,

I often heard this problem from board rev ~ *B.

So I'm surprised that you have this problem with rev. *D.

> Warning: The connected PSoC6 MCU device is out of date. Please contact Cypress to get a replacement

As the message states, you may need to contact Cypress about this problem.

I would suggest you note both the revision and the marking on the device of your board to inform Cypress.

On the other hand, with this warning message, my colleague could program the device and debug it with his program, I'm not sure if it had BLE function though.

So it may not be the root cause of your problem.

But to be on the safe side, I would suggest you acquire a board which could be programmed without this warning. 

moto

0 Likes

I tried contacting Cypress via email, and they directed me here.

0 Likes
MotooTanaka
Level 9
Level 9
Distributor - Marubun (Japan)
First comment on blog Beta tester First comment on KBA

Unfortunately, I'm not "Cypress" and it is the weekend now.

Let's hope someone from Cypress will contact/inform you about what to do with your problem.

I'm sorry for not being helpful.

moto

P.S. I lived in Colorado Springs, I loved living there 😉

0 Likes

Thanks anyway, moto.

On Sat, Feb 8, 2020, 5:34 PM Motoo Tanaka <community-manager@cypress.com>

0 Likes

This warning is displayed for kits w/ PSoC6A-BLE Silicon Revision (Rev.*B) and FlashBoot build version less than 29 because in this combination of Silicon and Flashboot, the build is broken and might cause numerous issues. Request you to update to the latest revision.

You will contacted by Cypress to provide you a replacement.

Regards,

Dheeraj

Some more info. from PSoC Programmer:

Installed CyInstaller Products:

Bridge Control Panel  1.20.0.4409

Clock Programmer  1.9.0.4409

Device Database  4409

Example Code  4409

PSoC Programmer  3.28.6.4409

USB Bootloader Application  4409

  Automatically Detected Device: CY8C6347BZI-BLD53

Silicon: 0xE207, Family: 0x100, Rev.: 0x22 (*B)

SROM Firmware: 2.01, Flash Boot: 1.0.1.20 (*B)

Protection state: 0x02 (NORMAL), Life Cycle stage: 0x01 (NORMAL)

The connected PSoC6 MCU device is out of date. Please contact Cypress to get a replacement

KitProg3. CMSIS-DAP Version 2.0.0. Firmware Version 1.01.158. Hardware Id 02.

0 Likes