Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Communication
Level 5
Level 5
100 replies posted First solution authored 250 sign-ins

Hi everybody!
Currently, I am implementing a program to consider the conditions to activate the engine as below!
However, my program does not study the condition of the humidity function nor the temperature function!. Does anyone know why or not. When I run the program even though the temperature and humidity are right, the motor still spins!

Thanks!

Communication_0-1684035591749.png

 

0 Likes
1 Solution
PandaS
Moderator
Moderator
Moderator
100 solutions authored 5 likes given 250 sign-ins

Hi @Communication ,

Could you please try entering the debug mode and putting a breakpoint at the humidity and temperature conditions.

Check if the program counter reached there or not.

Warm regards,

Sobhit

View solution in original post

0 Likes
5 Replies
PandaS
Moderator
Moderator
Moderator
100 solutions authored 5 likes given 250 sign-ins

Hi @Communication ,

Could you please try entering the debug mode and putting a breakpoint at the humidity and temperature conditions.

Check if the program counter reached there or not.

Warm regards,

Sobhit

0 Likes

How do I do it?

0 Likes

I do not understand what you mean?

0 Likes
PandaS
Moderator
Moderator
Moderator
100 solutions authored 5 likes given 250 sign-ins

Hi @Communication ,

To debug the application, please click on the debug with Miniprog3/4 below:

PandaS_0-1684350545650.png

Use the step over or step into tools to move through the code.

PandaS_1-1684350783015.png

And double click of the Blue bar to create a breakpoint:

PandaS_2-1684350830856.png

 

Warm regards,

Sobhit

0 Likes

Thanks!

0 Likes