Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

theaaronm
Level 2
Level 2
10 sign-ins 5 replies posted 5 questions asked

I have the PSoC 6 BLE Pioneer Kit CY8CKIT-062-BLE and am following along with the PSoC 6 101 Video Series. I am able to get the project generated successfully and get a "successfully programmed" message after programming in the output window, but have no LED response on my board and am unsure if it is even working.

0 Likes
1 Solution
MotooTanaka
Level 9
Level 9
First comment on KBA 1000 replies posted 750 replies posted

Hi,

This may not apply to you, but in the PSoC 6-BLE Pioneer Kit (CY8CKIT-062-BLE) web page

https://www.cypress.com/documentation/development-kitsboards/psoc-6-ble-pioneer-kit-cy8ckit-062-ble

There is the following table,

001-PDL-versions.JPG

If the Kit Revision of your board is *A or *B, you need to  use PDL 3.0.1.

If the Kit Revision of your board is **, I'm sorry but you are out of luck...

To specify the PDL revision, from PSoC Creator Menu

Project > Build Settings  

002-Build-Settings-PDL.JPG

And in the Peripheral Driver Library, select Custom and specify PDL\3.0.1

BTW, to get PDL 3.0.1, please access the following URL

https://www.cypress.com/design-guides/peripheral-driver-library-pdl-software-and-documentation-archi...

moto

 

View solution in original post

0 Likes
4 Replies
Aashita_Raj
Moderator
Moderator
Moderator
100 solutions authored 250 replies posted 250 sign-ins

Hi @theaaronm ,

I see that in the Lesson1-3: Hello World of PSoC 6 101 Video Series, there has been used 3 different methods to demonstrate the working of the project. Can you please let us know which method is failing for you to output as a blinking LED?

Also, can you please let us know if you have seen any warning while programming the CY8CKIT-062-BLE device for the first time or the device programmed without warnings?

Please let us know your comments regarding the above.

Best Regards,

Aashita

 

0 Likes

Hi Aashita,

Thank you for your reply, I have tried the first two methods from the video. The first method is using the built in PWM function and the second using the GPIO write function with a delays.

 

Thank you,

Aaron

0 Likes
MotooTanaka
Level 9
Level 9
First comment on KBA 1000 replies posted 750 replies posted

Hi,

This may not apply to you, but in the PSoC 6-BLE Pioneer Kit (CY8CKIT-062-BLE) web page

https://www.cypress.com/documentation/development-kitsboards/psoc-6-ble-pioneer-kit-cy8ckit-062-ble

There is the following table,

001-PDL-versions.JPG

If the Kit Revision of your board is *A or *B, you need to  use PDL 3.0.1.

If the Kit Revision of your board is **, I'm sorry but you are out of luck...

To specify the PDL revision, from PSoC Creator Menu

Project > Build Settings  

002-Build-Settings-PDL.JPG

And in the Peripheral Driver Library, select Custom and specify PDL\3.0.1

BTW, to get PDL 3.0.1, please access the following URL

https://www.cypress.com/design-guides/peripheral-driver-library-pdl-software-and-documentation-archi...

moto

 

0 Likes

I have Rev B of the kit and that fixed my issues!

 

Thank you,

Aaron