Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

Akash-USC
Level 1
Level 1
5 questions asked 5 sign-ins First reply posted

Hi,

 

I was trying to sample signal from a signal generator and was using the ADC to sample the signal.

I noticed that at 100Hz, there were 10 samples per cycle, and I was getting a good waveform for the same.  So, I felt that the sampling frequency may have been 1Khz, so I went on to change the SPS in the ADC, but whatever value I change it to, it seems to be not working. I do not want any averaging as such, but I also tried using averaging and that also did not work.

I am attaching the configuration of my ADC as well as the output from the ADC on an UART.

 

Could you please help me on the same?

Thanks in advance.

0 Likes
3 Replies
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi,

Averaging as such will decrease the effective sample rate as multiple samples are taken and they are averaged. Could you see if you are getting the required sample rate without averaging being enabled ?

Best Regards,
Vasanth 

0 Likes

Hi, Vasanth,

We turned averaging off as well and it did not work. As you can see on the screenshots attached, the Avg checkbox is unchecked. What should be my next approach?

Thanks in advance,

0 Likes
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi Akash,

Also check whether the ADC clock is set to proper frequency. The PSoC62 devices ADC clock can go upto 18MHz, which can help in achieving higher sampler rate.

Best Regards,
Vasanth

0 Likes