Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

Anonymous
Not applicable

Hi  all

     I now use PSOC 6 BLE passthrough, a transfer their 20 now no problem, but more than 20 bytes can't transfer, I in the schematic diagram of L2CAP L2CAPSettings MTU size set 251 bytes, but still won't do, if I need to set up there?

Thank you very much!

0 Likes
1 Solution

I tried the project and it seems like you are still using an older version of Creator/PDL combination. Can you please update to the latest Creator/PDL and try? We have updated BLE and MCWDT PDLs.

I am attaching a project that I tested in the release version of PSoC Creator 4.2 and it seem to work fine i.e. I first checked the 20 byte notification you were sending. Then I changed it to 200 bytes and I was seeing the notification in CySmart tool.

Let me know, if you still face issues after migrating to the latest Creator.

Another tip, when you create a custom notification service, please make sure you select proper data type and allocate enough size in the characteristic configuration window that appears on the right pane when select the characteristic in the BLE component. I did some clean up of the custom service - please take a look as well.

Regards,

Meenakshi Sundaram R

View solution in original post

0 Likes
5 Replies
MeenakshiR_71
Employee
Employee
100 likes received 50 likes received 25 likes received

Hello,

Is it possible for you to share the BLE settings and the project if possible. It is not clear from your description, what 20 bytes are you trying to transfer.

Is it a notification packet? Or a L2CAP logical channel packet? In case of notification packets, you should be changing the Attribute MTU size in the GATT settings tab (bottom left, below the services pane) and/or Link layer payload size in the Link layer settings tab. Even if the MTU is lower than 20 bytes, the notification packets of sizes greater than 20 bytes will be split into multiple ATT packets and sent. It should result in any failure. The MTU size in the L2CAP settings is for L2CAP logical channels defined and used by the user for direct L2CAP communication between the devices.

Regards,

Meenakshi Sundaram R

Anonymous
Not applicable

hi msur!

     I'm transmitting a notification package,Attached is the project,The hardware platform is psoc 6 BLE Pineer kit,In this project, I used to test the feature that BLE transmits more than 20 bytes. The test process is: after sending 20 bytes of data with a serial port, BLE would send N bytes of data.Please analyze it。

thanks。

0 Likes

I tried the project and it seems like you are still using an older version of Creator/PDL combination. Can you please update to the latest Creator/PDL and try? We have updated BLE and MCWDT PDLs.

I am attaching a project that I tested in the release version of PSoC Creator 4.2 and it seem to work fine i.e. I first checked the 20 byte notification you were sending. Then I changed it to 200 bytes and I was seeing the notification in CySmart tool.

Let me know, if you still face issues after migrating to the latest Creator.

Another tip, when you create a custom notification service, please make sure you select proper data type and allocate enough size in the characteristic configuration window that appears on the right pane when select the characteristic in the BLE component. I did some clean up of the custom service - please take a look as well.

Regards,

Meenakshi Sundaram R

0 Likes
ShipingW_81
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 250 replies posted

Guess the issue may caused by the default Attribute MTU size is 23 bytes. Payload is just ATT_MTU-3 = 20 bytes.

ATT_MTU size can be set up to 512 bytes in the BLE Component > GATT Settings > Attribute MTU Size manually.

0 Likes
Anonymous
Not applicable

hi fwan!

     I set the GATT Settings > Attribute MTU Size to 256, but cannot transfer over 20 bytes.

0 Likes