Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

AuKa_264411
Level 3
Level 3

I have just acquired a CY8CPROTO-062-4343W kit and downloaded Modus Toolbox 2.0 (and rebooted my system several times since then).. I am running WIndows 10.

I have tried following along with the videos Modus Toolbox 101 Lessons 1-1, 1-2, 2-1 and 2-2.

The screens are somewhat different- I attribute that to a difference between 2.0 and earlier versions.

One of the problems is there is no "Blinky" application in the list. So I thought I would try the "Hello World" application. It results in 2 errors which you can see below- however if they are illegible in the picture they read:

Error creating Eclipse launch configurations: Makefile:162: *** Unable to find any of the available CY_TOOLS_PATHS --  .  Stop.

Unable to find configurator information: Makefile:162: *** Unable to find any of the available CY_TOOLS_PATHS --  .  Stop.

And there are few of the files that I expected to see based on the videos including  the ability to look at the configuration

Based on my earlier work with Eclipse and Android, I am wondering if I need to add entries to my parh.

Anybody have any clue as to what to do.

PSOC6Error.png

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Yes the videos are for ModusToolbox 1.1. Though the application code remains mostly the same , the flow in ModusToolbox 2.0 is slightly different. Please refer to the following documents on ModusToolbox 2.0 to get you started:

When you were installing ModusToolbox, did you change the default folder name "ModusToolbox" to something else? Please note that when you create the application it tries to locate the "tools_2.0" folder present in the installation directory.  If you installed ModusToolbox to a custom location, please add the path in "CY_TOOLS_PATHS+=" as shown below:

makefile.PNG

Or if you changed the name of the default folder to "ModusToolbox_20" for example, then just change the name in the "CY_TOOLS_PATHS ?=" to "$(CY_WIN_HOME)/ModusToolbox_20/tools_* \"

Let me know if this solves your issue.

Regards,
Dheeraj

View solution in original post

2 Replies
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Yes the videos are for ModusToolbox 1.1. Though the application code remains mostly the same , the flow in ModusToolbox 2.0 is slightly different. Please refer to the following documents on ModusToolbox 2.0 to get you started:

When you were installing ModusToolbox, did you change the default folder name "ModusToolbox" to something else? Please note that when you create the application it tries to locate the "tools_2.0" folder present in the installation directory.  If you installed ModusToolbox to a custom location, please add the path in "CY_TOOLS_PATHS+=" as shown below:

makefile.PNG

Or if you changed the name of the default folder to "ModusToolbox_20" for example, then just change the name in the "CY_TOOLS_PATHS ?=" to "$(CY_WIN_HOME)/ModusToolbox_20/tools_* \"

Let me know if this solves your issue.

Regards,
Dheeraj