Modus toolbox compilation error on empty project with custom BSP

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
Manusharian_
Level 1
Level 1
First solution authored 5 sign-ins First reply posted

Hello everyone,

We have a product based on CY8C6347LQI-BLD52 module and the application is a dual core application with OTA support (has Laucher, Stack, and Application projects), developed in PsocCreator (with custom modified PDL files). We start again working on this project, but to my surprise, PSOC Creator is no longer able to load the project and of course the support for LQI chip is no longer there. Thus, I started to port the project to ModusTool box under Mac OS distribution. As I have read on the forum, the recreation of an OTA application with all 3 projects in Modus Toolbox is another challenge, but so far I wanted to make a simple application compilable and to try and run it on our custom board.

I have created a project with a custom BSP based on the CY8C6347LQI-BLD52 chip, I have selected PDL and not HAL for the drivers support and basically all the libraries that are added with an Empty Dual Core project. When I compile the project, I just get flash overflow error from the linker (even if the app has only the main.c) and I am not sure what to do. I have attached the project, but basically is the empty dual core example and the log from modus. 

Can someone point me to a direction regarding this error? Is it a better idea to maybe use the BZI chip and try to load the code on the LQI one? (I can confirm that the BZI chip complies successfully with the empty app).

It seems that this is one of many questions that I will ask regarding the modus toolbox.

Thanks in advance,

Marian

0 Likes
1 Solution

Hello,

Thank you! It seems the problem was documented in some application note and it was present also here on the forum (https://community.infineon.com/t5/PSoC-6/Modustoolbox-3-Dual-core-empty-app-for-Psoc62/td-p/378629). I did not see it earlier and also I am not sure why this still happens. Please do check that part. Meanwhile I was able to compile it after manually changing the linker FLASH size.

Thank you!

View solution in original post

0 Likes
3 Replies
LinglingG_46
Moderator
Moderator
Moderator
500 solutions authored 1000 replies posted 10 questions asked

Hi,

I can reproduce your issue from myside.

I will report it internal and give you feedback as soon as possible.

Thanks

 

0 Likes

Hello,

Thank you! It seems the problem was documented in some application note and it was present also here on the forum (https://community.infineon.com/t5/PSoC-6/Modustoolbox-3-Dual-core-empty-app-for-Psoc62/td-p/378629). I did not see it earlier and also I am not sure why this still happens. Please do check that part. Meanwhile I was able to compile it after manually changing the linker FLASH size.

Thank you!

0 Likes

Thanks for the sharing, I also can compile it after manually changing the linker flash size.

0 Likes