Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
ravo
Level 5
Level 5
10 likes received 5 comments on blog 5 solutions authored

Dears,

I am unable to find "Tool Settings" under C/C++ Build as shown in some tutorials, manuals for Modus Toolbox IDE. Where are these settings in Modus Toolbox IDE - 2.4.0 version ? In previous release it was under Project Properties: C/C++ Build -> Settings as shown on this picture:

53febd18-c48e-495f-8440-a87d614a619d.jpg

And for comparison - In 2.4.0 release the "Tool Settings" tab is missing:

a98c72ab-e272-4856-8bd3-bad4c678eb44.jpg

Thanks in advance and Best Regards

Radim

0 Likes
1 Solution
Rakshith
Moderator
Moderator
Moderator
250 likes received 1000 replies posted 750 replies posted

Hi Radim, 

Can you please let us know which setting are you looking for? In the recent versions of ModusToolbox, most of the settings related to the compiler are deferred to the makefile. So if there is any particular setting that you are looking for then please let us know. We will try to provide a workaround for the same.

In the image, I see that you have highlighted the usage of hardfp. For that, you can refer to this snapshot from the ModusToolbox User Guide

Rakshith_1-1654840122938.png

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
3 Replies
Rakshith
Moderator
Moderator
Moderator
250 likes received 1000 replies posted 750 replies posted

Hi Radim, 

Can you please let us know which setting are you looking for? In the recent versions of ModusToolbox, most of the settings related to the compiler are deferred to the makefile. So if there is any particular setting that you are looking for then please let us know. We will try to provide a workaround for the same.

In the image, I see that you have highlighted the usage of hardfp. For that, you can refer to this snapshot from the ModusToolbox User Guide

Rakshith_1-1654840122938.png

Thanks and Regards,
Rakshith M B
0 Likes
ravo
Level 5
Level 5
10 likes received 5 comments on blog 5 solutions authored

Dear Rakshith,

thanks for response. I missed to see these notes in manual. I would like to see all settings related to FPU unit in PSOC6. If it is some settings still in IDE or all only in Makefile now.

e.g. these params:

DEFINES=ARM_MATH_CM4 ...
VFP_SELECT= hardfp or softfp // We are not able to use pure "soft" ?
CFLAGS =-mfloat-abi=...

I would like to test both soft & hard version - but compiled version in assembly is still same as described in another thread https://community.infineon.com/t5/PSoC-6/PSoC6-FPU-in-GCC-compiler-in-Modus-Toolbox-environment/td-p...

Regards

Radim

0 Likes
Rakshith
Moderator
Moderator
Moderator
250 likes received 1000 replies posted 750 replies posted

Hi Radim, 

I believe the thread that you have shared is now resolved.

Thanks and Regards,
Rakshith M B
0 Likes