Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Level 3
Level 3

I am trying to test the RTC of the PSoC 6 BLE Pioneer Kit. I move sw7 to super cap to Power VBackup when no power is available. When I do, the MiniProg 3 gets an error when I try to start the debugger inside the Creator :

There was an error while programming the device: PSoC Programmer reported error

(100 - EraseAll API returned: Error code 0x003DF1DC: Unknown SROM status code)

How do I verify that the super cap will power the RTC during no power configuration?

5 Replies
100 likes received 50 likes received 25 likes received

Can you try the option "Attach to running target" under Debug in Creator.

MiniProg3 is using reset mode of programming or Power Cycle mode of programming?

500 replies posted 250 solutions authored 250 replies posted

Hi Andrew,

What else you have changed other than moving sw7 to super cap on the board?

I can program and debug finely with same scenario of yours.

The power supply of backup domain maybe actually not switched to super cap even though sw7 switched correctly, because VDDD is always supplied as long as Miniprog3 supplies power to the board.

If VDDD is available, backup power switch will always selects VDDD as power source. If the user wants to use VBACKUP as backup domain power source for debug purpose, the VDDBAK_CTL bitfield in the BACKUP_CTL register should be set as non-zero value.

Also, please enable charging the super cap firstly(through VBACKUP when VDDD is available), by writing "3C" to the EN_CHARGE_KEY bitfield in the BACKUP_CTL register.


Returning sw7 to VDDD/KitProg2 has no affect.

sw6 is set to PSoC 6 BLE.

I have tried all clock speeds; now set at 0.2 MHz.

I am using SWD protocol, 10 pin,  Reset acquire, and 3.3 power. (Error Below)


Setting power to External and supplying power (12VDC) with J9. (Error Below)


So what I am doing wrong?


I retraced my steps and was able to program and debug. I changed Power supplies to a bench supply instead of a wall wart. I then started with the PSoC 6 programmer and tried the Creator after that was working. Everything was updated, so that wasn't it.  However, this was a demo of the RTC and not the main project.

The main point is to have a factory programmer without KitProg2.

I did have the line below in main() (for anks).

Cy_SysPm_BackupSuperCapCharge( CY_SYSPM_SC_CHARGE_ENABLE );

This still has problems:

  • no uart
  • sw7 is set to KitProg2



Sorry for late reply.

Seems still not clear enough for the issue. Can you clarify more about the problems you are facing?