Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
LeoMathews
Moderator
Moderator
Moderator
First question asked 500 replies posted 100 solutions authored

Originally very normal, suddenly unable to download the code, the following is the console display info?

 

Started by GNU MCU Eclipse
Open On-Chip Debugger 0.10.0+dev-4.1.0.1058 (2020-08-11-03:47)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
Info : auto-selecting first available session transport "swd". To override use 'transport select <transport>'.
adapter speed: 2000 kHz
adapter srst delay: 25
adapter srst pulse_width: 25
** Auto-acquire enabled, use "set ENABLE_ACQUIRE 0" to disable
cortex_m reset_config sysresetreq
Warn : SFlash programming allowed for regions: USER, TOC, KEY
Info : CMSIS-DAP: SWD Supported
Info : CMSIS-DAP: FW Version = 2.0.0
Info : CMSIS-DAP: Interface Initialised (SWD)
Info : SWCLK/TCK = 1 SWDIO/TMS = 1 TDI = 1 TDO = 1 nTRST = 0 nRESET = 1
Info : CMSIS-DAP: Interface ready
Info : KitProg3: FW version: 2.21.1005
Info : KitProg3: Pipelined transfers enabled
Info : VTarget = 3.328 V
Info : kitprog3: acquiring the device...
Error: kitprog3: failed to acquire the device
Info : clock speed 2000 kHz
Error: DAP 'psoc6.cpu' initialization failed (check connection, power, etc.)
Info : psoc6.dap: powering down debug domain...
Warn : Failed to power down Debug Domains

0 Likes
1 Solution
LeoMathews
Moderator
Moderator
Moderator
First question asked 500 replies posted 100 solutions authored

The following can be the possible reasons for showing this error and the corresponding solutions for each reason are given:

  1. The development kit or custom board may not be in default hardware configuration:

Solution: Ensure the kit is in the default hardware configuration. (The jumpers may be misplaced. Correct them by referring to the user manual).

  1. Check the mode of the kitProg device(checking the kitProg status LED) . The default mode must be set to CMSIS-DAP BULK.
  2. Ensure you are programming the correct target MPN(of the PSoC device).

View solution in original post

0 Likes
1 Reply
LeoMathews
Moderator
Moderator
Moderator
First question asked 500 replies posted 100 solutions authored

The following can be the possible reasons for showing this error and the corresponding solutions for each reason are given:

  1. The development kit or custom board may not be in default hardware configuration:

Solution: Ensure the kit is in the default hardware configuration. (The jumpers may be misplaced. Correct them by referring to the user manual).

  1. Check the mode of the kitProg device(checking the kitProg status LED) . The default mode must be set to CMSIS-DAP BULK.
  2. Ensure you are programming the correct target MPN(of the PSoC device).
0 Likes