Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
PaGy_1246781
Level 2
Level 2
5 replies posted 5 questions asked First like received

Hello All,

I'm trying to use the CSDADC middleware to measure the voltage at VDDA.  The initialization function Cy_CSADC_Init always causes a fault.  The fault occurs in the function Cy_CSD_GetVrefTrim, which is called by Cy_CSDADC_Init.  The fault occurs when it tries to read SFLASH_CSD0_ADC_VREF0_TRIM, which is stored in supervisory flash.

Since the code is Cypress supplied, one would assume that it has been tested.  So, I'm wondering if there's anything I need to do to enable reading of supervisory flash.  Any ideas?

Paul

0 Likes
1 Solution
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi Paul,

From our test on CE227251 - PSoC 6 MCU: CSD Analog to Digital Converter (ADC), the API did not have any problem. Could you please let me know what hardware are you using ? Will you be able to share the project. In your project can you check confirm the VDDA on the board and VDDA given on system tab, power sub menu.

Best Regards,

Vasanth

View solution in original post

0 Likes
2 Replies
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi Paul,

From our test on CE227251 - PSoC 6 MCU: CSD Analog to Digital Converter (ADC), the API did not have any problem. Could you please let me know what hardware are you using ? Will you be able to share the project. In your project can you check confirm the VDDA on the board and VDDA given on system tab, power sub menu.

Best Regards,

Vasanth

0 Likes

Hi Vasanth,

Thanks for the reply.  I believe my problem is the result of a platform limitation.

I am using a third party RF module that has a PSoC 6 on board.  The M4 core is available to the user, but the M0+ core is locked down with the vendor's code.  I now believe that the vendor has protected part or all of the SFlash.  I am waiting for confirmation.  If I am right, then this is not a Cypress issue, but a vendor issue.

Best Regards,

Paul

0 Likes