Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

vim_2255711
Level 2
Level 2
5 replies posted First question asked First solution authored

Hi, 

Framework MTB SDK
Board:PSoc 62S2

I tried connect to hidden ssid  by giving only mac address, security type and channel number and SSID len as with zero len and SSID empty string, here BSSID is hard coded for test purpose and made SSID to empty explicitly.
I Used  
whd_wifi_join_specific to  join, in this API I commented SSID length sanity check.  after using this  am not able connect to hidden SSID, 
```

whd_wifi_join_specific: set_ssid result (err 0); left network
whd_wifi_join_wait_for_complete: not ready to transceive (err 33555457); left network
Function whd_wifi_join_specific failed at line 1677 checkres = 33555457
Failed to join AP [33555457]. Retrying...
IN whd_wifi_join_specific
whd_wifi_join_specific: set_ssid result (err 0); left network
whd_wifi_join_wait_for_complete: not ready to transceive (err 33555457); left network
Function whd_wifi_join_specific failed at line 1677 checkres = 33555457
Failed to join AP [33555457]. Retrying.


```
but when I change this SSID as  active network in AP, am able to connect.  Please let me know if am missing something.
@vsubbiah 

0 Likes
1 Solution
AditiB_81
Moderator
Moderator
Moderator
5 questions asked 250 replies posted 250 sign-ins

Hi,

Is it possible to provide your code example to reproduce the issue in our setup? Also, have you enabled debug macros -  

define WPRINT_ENABLE_WHD_ERROR
define WPRINT_ENABLE_WHD_DEBUG
 
If not, please enable these and provide the debug prints to better understand the issue. Please provide the debug call stack as well to get the exact function which is failing.
 
Thanks
Aditi

View solution in original post

0 Likes
1 Reply
AditiB_81
Moderator
Moderator
Moderator
5 questions asked 250 replies posted 250 sign-ins

Hi,

Is it possible to provide your code example to reproduce the issue in our setup? Also, have you enabled debug macros -  

define WPRINT_ENABLE_WHD_ERROR
define WPRINT_ENABLE_WHD_DEBUG
 
If not, please enable these and provide the debug prints to better understand the issue. Please provide the debug call stack as well to get the exact function which is failing.
 
Thanks
Aditi
0 Likes