Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

WaYa_2582946
Level 1
Level 1

Hello, Cypress. On the CY8CKIT-062-BLE, switch setting follows the CY8CKIT guide, and work very well at first. A few days later, after I successfully programmed it, I powered the kit off and on, it can not be programmed. Both of the PSoC Creator and PSoC Programmer show "Failed to Acquire Device". I checked all the connection and setting, everything is the same with the condition when it worked. This problem makes my work held up for few days. 

0 Likes
6 Replies
SrikanthD_56
Employee
Employee
First comment on blog 100 replies posted 50 solutions authored

Hi

Please provide the screenshot of the error you are seeing in PSoC Programmer when you try to program the device.

Also check out this thread PSOC 6 BLE kit does not connect to USB

0 Likes
WaYa_2582946
Level 1
Level 1

Programmer.png

0 Likes

From the screenshot it appears that PSoC Programmer (KitProg2) is unable to talk to the device.

Please check your hardware setup carefully (perhaps one more time). Change switch position back and forth once to ensure position alignment.

If you have a MiniProg3, connect it to J11 on the kit and see if you can program the device successfully.

0 Likes

Thank you for reply. I followed your advice and change switch back and forth. Still doesn't work.

I don't have MiniProg3, but I have ULINK2 and it can not program also.

0 Likes

Please check out this thread (CY8CKIT-062-BLE I can not programming psoc63 chip) and see if that is of any help.

0 Likes
TareeshK_21
Employee
Employee
5 replies posted First solution authored First reply posted

you can try the following and see if it helps,

put SW5 in variable mode (lower position)  and set the voltage to 2.5 using Programmer.

then you can try to do checksum (doesn't matter what hex file you have loaded) and see if the device is getting acquired.

0 Likes