Announcements

Ever wondered how you could shape the future in collaboration with others? Join us at OktoberTech Asia Pacific and get inspired. Click here to sign up FREE of charge.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

NiBu_4687336
Level 5
5 solutions authored 50 replies posted 25 replies posted
Level 5

Hi.

I just updated to the latest libraries, and ModusToolbox 2.4, and ran into problems. I tracked them down to the fact that compile_commands.json no longer includes "-DCOMPONENT_CAT1" as part of the compiler command line. It used to define both COMPONENT_CAT1 and COMPONENT_CAT1A, but now only defines COMPONENT_CAT1A.

This breaks, among other things, _cyhal_utils_get_clock_count(), which now returns a value of 1 for all clock types.

I've worked around the problem by adding "CAT1" to the definition of COMPONENTS in my Makefile, but clearly that's not how it's supposed to work.

What happened? Did I do something wrong, or fail to follow some update procedure, or is this an oversight by Cypress developers?

Thanks,

-Nick

0 Likes
1 Solution
NiBu_4687336
Level 5
5 solutions authored 50 replies posted 25 replies posted
Level 5

Hi @AlenAn14.

The problem was resolved by updating the BSP. Apparently, libraries aren't really backward compatible.

Thanks,

-Nick

View solution in original post

0 Likes
3 Replies
AlenAn14
Moderator
Moderator 500 replies posted 100 solutions authored 250 replies posted
Moderator

Hi @NiBu_4687336 ,

Can you please let me know the device/evaluation board which you are using to test your firmware ?

Warm Regards
Alen

0 Likes
NiBu_4687336
Level 5
5 solutions authored 50 replies posted 25 replies posted
Level 5

Hi @AlenAn14.

The problem was resolved by updating the BSP. Apparently, libraries aren't really backward compatible.

Thanks,

-Nick

0 Likes
AlenAn14
Moderator
Moderator 500 replies posted 100 solutions authored 250 replies posted
Moderator

Hi @NiBu_4687336 ,

Glad your issue is resolved and thank you for sharing the solution with the community!

The major version changes in the libraries are not backward compatible, like v1.x.x to 2.x.x.

Warm Regards
Alen

0 Likes