Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
alca_3047856
Level 1
Level 1
10 sign-ins 5 questions asked 5 sign-ins

Does anyone know of this issue?

I am using the example project:  CE212736 - PSoC 6 MCU with Bluetooth Low Energy (BLE) Connectivity - Find Me

In cy_ble_gap.h which has been generated by the ide, there is a define:  #define CY_BLE_ADVERTISING_FAST                    (0x00u)

In main_cm4.c    you can use the define: 

if(CY_BLE_ADVERTISING_FAST){

//do something

}

In main_cm0p.c   this same code is not working.  It cannot find the definition for CY_BLE_ADVERTISING_FAST.

What I am trying to do is move all of the bluetooth code over to the cm0.  This project currently runs the ble handler on the cm4.  There is a lot of ble code that is generated by the IDE, and the cm0 for some reason is not able to access the files.

Any help on this would be greatly appreciated.

0 Likes
1 Solution
SrikanthD_56
Employee
Employee
25 sign-ins First question asked First comment on blog

To access CY_BLE_ADVERTISING_FAST macro from main_cm0p.c, change the CPU core: parameter to Single core (Complete Component on CM0+) from the drop-down in the BLE component's General settings.

View solution in original post

0 Likes
1 Reply
SrikanthD_56
Employee
Employee
25 sign-ins First question asked First comment on blog

To access CY_BLE_ADVERTISING_FAST macro from main_cm0p.c, change the CPU core: parameter to Single core (Complete Component on CM0+) from the drop-down in the BLE component's General settings.

0 Likes