Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
KeRa_4680976
Level 1
Level 1

Is there a BLE sample project that I can program the CY8CKIT-062 board with using the Modus Tools IDE?

When I select New Application and choose my kit I do not see anything for BLE within the sample projects. If I select the BLE kit I see plenty of sample projects demonstrating BLE, however, when I attempt to program my board with any of the BLE kit sample projects nothing works. I'm sure this is because my board is not supported.

0 Likes
1 Solution

Hello Kevin,

I'm sorry my bad. I misread the kit you are using. Please note that BLE projects won't work on the CY8CKIT-062-WIFI-BT Pioneer Kit. PSoC62 devices do not have support for BLE.

You will need to use PSoC6 BLE Pioneer Kit which has an onboard BLE 5.0 compliant PSoC63 device.

Please go to the Products tab at this link to distinguish between the different features of the PSoC6 line of devices.

Regards,

Dheeraj

View solution in original post

0 Likes
3 Replies
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Please download the latest ModusToolbox software from here in case you are on the older version.

When you click the New Application Wizard, you will see a dialog prompt to select the Board Support Package (BSP). Choose CY8CKIT-062-BLE and click Next. You will find a list of application templates to choose from as shown below:

pastedImage_4.png

And as you can see, there are some BLE examples to get started with.

Please note that for the board to work with ModusToolbox, you will need the latest version as shown below:

version.PNG

To find out if your kit is not supported, please connect your kit to PSoC Programmer or Cypress Programmer and perform an erase operation. If you see the message "Your PSoC6 KIT is out of date. Please contact Cypress to get a replacement." let us know.

Regards,

Dheeraj

0 Likes
lock attach
Attachments are accessible only for community members.

Thank you for the detailed reply. I have tried to load several BLE sample

projects before but to no avail. It appears as though the project is

successfully loaded onto the board according to the Modus Toolbox console

but I cannot find the device using the CySmart application.

Please find attached a Photo of the back of the PSoC 6 WiFiBT Pioneer Kit

along with a Photo of the "Erase All Flash" as successfully being performed

with PSoC Programmer.

Thanks,

Kevin

On Tue, Apr 14, 2020 at 1:06 AM DheerajK_81 <community-manager@cypress.com>

0 Likes

Hello Kevin,

I'm sorry my bad. I misread the kit you are using. Please note that BLE projects won't work on the CY8CKIT-062-WIFI-BT Pioneer Kit. PSoC62 devices do not have support for BLE.

You will need to use PSoC6 BLE Pioneer Kit which has an onboard BLE 5.0 compliant PSoC63 device.

Please go to the Products tab at this link to distinguish between the different features of the PSoC6 line of devices.

Regards,

Dheeraj

0 Likes