公告

大中华汽车电子生态圈社区并入开发者社区- 更多资讯点击此

Tip / 登入 to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Translation_Bot
Community Manager
Community Manager
Community Manager

我已经阅读了几篇关于创建自定义 BSP 的不同文章和教程,但是在尝试构建 BSP 时遇到了以下错误,既有来自 ModustoolBox (3.1),也有来自命令行(以下来自命令行尝试):

使 bsp TARGET_GEN=my-bsp DEVICE_GEN=CY8C6136BZI-F14

工具目录:/home/test/modustoolbox/Tools_3.1

正在移除.mtbqueryapi 文件...

正在搜索已安装的工具...

搜索已安装的工具已完成

../mtb_shared/core-make/release-v3.2.2/make/core/core_utils.mk: 109:*** 不再支持 Make bsp 目标。 改用 BSP 助手工具...停下来。

这是从顶级项目目录执行的。 我遵循了 ModustoolBox 的安装指南,相信我已经完成了所有步骤。 有人能解释一下为什么会发生这种情况吗?

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/PSoC-6/make-bsp-no-longer-supported/td-p/640183

0 点赞
1 解答
Translation_Bot
Community Manager
Community Manager
Community Manager

1:请下载并安装最新版本的 ModustoolBox。

ModusToolbox™ 可作为三个操作系统(Windows、Linux、macOS)的安装程序使用。 您可以访问英飞凌开发人员中心并搜索 ModusToolbox™,或 单击此处直接进入下载页面。

2:现在你可以参考 bsp 助手来更改设备号。 您可以单击此处获取 BSP 助手用户指南。

3:不再支持 m " ake bsp 目标。", 它应该提及第 2 点。这些原始方法已经过时了。

在原帖中查看解决方案

0 点赞
1 回复
Translation_Bot
Community Manager
Community Manager
Community Manager

1:请下载并安装最新版本的 ModustoolBox。

ModusToolbox™ 可作为三个操作系统(Windows、Linux、macOS)的安装程序使用。 您可以访问英飞凌开发人员中心并搜索 ModusToolbox™,或 单击此处直接进入下载页面。

2:现在你可以参考 bsp 助手来更改设备号。 您可以单击此处获取 BSP 助手用户指南。

3:不再支持 m " ake bsp 目标。", 它应该提及第 2 点。这些原始方法已经过时了。

0 点赞