Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 SDK Forum Discussions

deepakhm09
Level 1
Level 1
10 sign-ins 5 sign-ins First reply posted

Hi All,

 

In one of our project we are using the above mentioned psoc. We are using SD card and we are using emfile Filesystem and I am trying to add this library in to the securebliky project using library manager. I am facing the build errors as attached in the log file. 

I need help to create this project with emfile Filesystem please suggest me the correct procedure.

 

Thanks

Deepak H M

0 Likes
8 Replies
LeoMathews
Moderator
Moderator
Moderator
100 sign-ins 25 solutions authored 100 replies posted

Hi @deepakhm09 

Can you please try update the emfile library to the latest version as shown?

LeoMathews_0-1673423308271.png

And then try building the project again. Please observe whether the error exists.

Thanks and Regards,
Leo

0 Likes
deepakhm09
Level 1
Level 1
10 sign-ins 5 sign-ins First reply posted

Hi @LeoMathews

Thanks for the quick response I tried the suggestion and still the error is persisted. PFA for the more info.

Thanks

Deepak H M 

0 Likes
LeoMathews
Moderator
Moderator
Moderator
100 sign-ins 25 solutions authored 100 replies posted

Hi @deepakhm09 

After adding emfile using the library manager to your project, please edit the makefile as shown.

LeoMathews_0-1673612109938.png

and 

LeoMathews_1-1673612130318.png

After making the edits in the makefile please rebuild the project.

Thanks and Regards,
Leo

0 Likes
deepakhm09
Level 1
Level 1
10 sign-ins 5 sign-ins First reply posted

Hi @LeoMathews 

As suggested, I tried with Makefile changes, I am seeing different errors. PFA and thanks for the replay.

Thanks

Deepak H M

0 Likes
LeoMathews
Moderator
Moderator
Moderator
100 sign-ins 25 solutions authored 100 replies posted

Hi @deepakhm09 

Looks like the errors arise because the v4.1.0 of the BSP used is updated to use HAL v2.0.0. As it is a major update, it is not backward compatible with code examples that use older versions. To fix the project, user needs to manually update the code to use HAL v2.0.0 API and the list of changes to be done are mentioned are provided here.

Thanks and Regards,
Leo

 

0 Likes
deepakhm09
Level 1
Level 1
10 sign-ins 5 sign-ins First reply posted

Hi @LeoMathews 

Thanks for the replay. The Issue is on the other hand I am importing emfile middleware to secureblinky application so this secureblinky is already using HAL v2.0.0 I need input on how to upgrade emfile middleware to access these API's.

Thanks

Deepak H M

 

0 Likes
LeoMathews
Moderator
Moderator
Moderator
100 sign-ins 25 solutions authored 100 replies posted

Hi @deepakhm09

Can you please look refer to this User Guide and check if it helps?

Thanks and Regards,
Leo 

0 Likes
deepakhm09
Level 1
Level 1
10 sign-ins 5 sign-ins First reply posted

Hi @LeoMathews ,

Thanks for the replay, I was on long leave will check and will come back.

 

Thanks

Deepak H M

0 Likes