Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

vnguyen28
Level 1
5 sign-ins First question asked First reply posted
Level 1

Hi! When I create a new project for psoc 5 LP. A window pops up saying cy_isr_v1_71 datasheet is not available in English. After placing an Interrupt component on the Top Design and build the project, a lot of errors come up, all about the generated isr.c and isr.h file. I have attached some screen shots of the problem.

I have tried remove everything and re-install Psoc Creator but the problem still persists. Please help.

0 Likes
1 Solution
Aashita_Raj
Moderator
Moderator 100 solutions authored 250 replies posted 250 sign-ins
Moderator

Hi @vnguyen28 ,

I have attached cy_isr_v1_71 zip file here for your reference. Can you please unzip and include this file in the folder of cylib of PSoC Creator version which you are using? For e.g. I have it here -> File Explorer->Documents\PSoC Creator\4.2\Downloads ( 4.2).cylib

Can you please check and follow this? Please try to build after this and let us know the result.

Best Regards,

Aashita

 

View solution in original post

0 Likes
3 Replies
Aashita_Raj
Moderator
Moderator 100 solutions authored 250 replies posted 250 sign-ins
Moderator

Hi @vnguyen28 ,

So as to re-create the issue at our end, I tried the exact same schematic as yours using cy_isr_1_71 component as shown in below image -

Aashita_Raj_0-1656653517489.png

And the build is successful for me. Can you please let me know if I am missing some information from your end here?

Also, what is your application? Are you trying to use GPIO as Interrupt? If that is so, you can try referring "Interrupts Example" code example from here -> Open PSoC Creator -> Code Example -> Family = PSoC 5LP -> Interrupts Example. I have also attached it here for your convenience.

Best Regards,

Aashita

 

 

0 Likes
vnguyen28
Level 1
5 sign-ins First question asked First reply posted
Level 1

Hi Aashita,

Thank you for your response and the attached sample code.

I downloaded the example and successfully built the project. However, I notice that the interrupt component is in version 1.70.

And for verification, I dragged the interrupt component that is on the Component Catalog panel, which is version 1.71. I tried to build it and got the same error as I mentioned initially. 

In addition, I am able to compile and build the exact same project on another computer, I only have this problem on my laptop. I instinctively think that this has something to do with the interrupt v1.71 on my laptop, so I go ahead and re-install the whole thing. And that did not help.

The root of the problem here I think is the message cy_isr_v1_71 is not available with a translation in English. Do you have any idea what that means and how to verify that?

Thank you,

 

 

0 Likes
Aashita_Raj
Moderator
Moderator 100 solutions authored 250 replies posted 250 sign-ins
Moderator

Hi @vnguyen28 ,

I have attached cy_isr_v1_71 zip file here for your reference. Can you please unzip and include this file in the folder of cylib of PSoC Creator version which you are using? For e.g. I have it here -> File Explorer->Documents\PSoC Creator\4.2\Downloads ( 4.2).cylib

Can you please check and follow this? Please try to build after this and let us know the result.

Best Regards,

Aashita

 

0 Likes