Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

donaldjmanurung
Level 1
Level 1
5 sign-ins First reply posted First question asked

Dear Sir/ Madam

I have some technical problems when used Cy8c38xxx family processor module. When i tried to program the chip by clicking the program/debug button, it can not be programmed. An error message displayed which is "Warning: dbg.M0039: There was an error running port acquire.  There may be no devices attached, or a device may be in use by another application". Then i tried to reduce the clock speed but it still didn't work. I used CY8CKIT-001 Development Kit. 

Do you have any suggestions?

Or, Is PSoC 3 can not be used more?

Thanks and Regards

0 Likes
1 Solution
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hello @donaldjmanurung 

Could you please let me know from where have you purchased the processor module? 

In case you have purchased the kit from a distributor you can ask him to create an RMA case with Infineon.

Also, you are correct the processor module is no longer manufactured and you can look for similar development kits with CY38xxx chips like the CY8CKIT-030A and see if it meets your requirement: https://www.infineon.com/cms/en/product/evaluation-boards/cy8ckit-030a/

Best Regards
Ekta

View solution in original post

3 Replies
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hello @donaldjmanurung 

PSoC 3 is still supported.
There can be multiple reasons why you are seeing this error:

1. Please make sure that the USB cable that you are using for programming is working properly.
2. Ensure that the board is properly powered, check your power supply wires.
3. Make sure that your device is not acquired by any other application in the background like Bridge control panel, PSoC Programmer (in case you are using PSoC Creator for programming) etc.
4. Check if you have made proper settings for the port configuration:

Please go to tools>options>program/debug>Port Configuration> in PSoC Creator
In PSoC Programmer, these options are available under the Programmer tab.

You can also refer to a similar thread which mention this issue: https://community.infineon.com/t5/PSoC-5-3-1/Port-Acquire-Error/m-p/107492

Best Regards
Ekta

0 Likes
donaldjmanurung
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hi Ekta,

Thanks for the response

I have tried your suggestions but it still didn't work (the error message still displayed). After I check all the power supply cable etc, i found that the device is damage. Because when i tried to use other processor modules, the device is powered but when i used the damage processor module, the device is not powered. I saw it on PSoC programmer. I want to ask, How can i change or order the new one? Because according to information, the processor module (CY8C38xxx) is not manufactured more.

P.S : i attached the photo of the processor module

Thanks & Regards,

Donald

WhatsApp Image 2022-01-05 at 20.32.49.jpg

0 Likes
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hello @donaldjmanurung 

Could you please let me know from where have you purchased the processor module? 

In case you have purchased the kit from a distributor you can ask him to create an RMA case with Infineon.

Also, you are correct the processor module is no longer manufactured and you can look for similar development kits with CY38xxx chips like the CY8CKIT-030A and see if it meets your requirement: https://www.infineon.com/cms/en/product/evaluation-boards/cy8ckit-030a/

Best Regards
Ekta