Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

MaCa_3412756
Level 1
Level 1

We're designing a new product based on CY8CKIT-033A. We use the midi interface to control an application running on iPhone device.

After the last update to iOS13 midi interface doesn't work properly. The midi interface is recognized by the app only the first time. After a disconnection there's no way to restore the midi link.  Only a swith off and switch on of the iPhone restore the link for one shot. Before the iOS update everything worked fine. Does Cypress provide to fix this bug?

Thank you

Mario Caramanico

0 Likes
4 Replies
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hello Mario,

Can you please attach your project. This will help us to recreate the issue at our side and get further inside of the problem.

Best Regards

Ekta

0 Likes

Hello Ekta,

actually we’re using the default software for the development kit (see attachment). We connect a midi pedal board on the Midi In1 of midi interface and analyze the midi incoming signal with the app “midi scope” version 1.4 running on an iPhone 6s with iOS 13. With the same setup but with iOS 12 we had always a right functionality in term of connection between development kit and iPhone and in term of received data. After the update to iOS13 some problem arise.

In order to analyze the connection robustness we disconnect/reconnect the power supply on J306 of the development kit.

We have two sort of failure:

· the iPhone shutdown alone

· the development kit get stuck with the display freeze on “Inizializing iAP”

We’re completely available to provide any further information you believe helpful

Best regards

Mario

Da: EktaN_26 <community-manager@cypress.com>

Inviato: venerdì 4 ottobre 2019 08:26

A: Mario Caramanico <mario@markbass.it>

Oggetto: Re: - Problem with dev kit CY8CKIT-033A midi interface

<http://www.cypress.com>

<https://community.cypress.com/?et=watches.email.thread> Cypress Developer Community

Problem with dev kit CY8CKIT-033A midi interface

reply from EktaN_26 <https://community.cypress.com/people/EktaN_26?et=watches.email.thread> in PSoC 3 - View the full discussion <https://community.cypress.com/message/211043?et=watches.email.thread#211043>

0 Likes

Ekta,

hereafter a picture of the setup

Regards

Mario

Da: EktaN_26 <community-manager@cypress.com>

Inviato: venerdì 4 ottobre 2019 08:26

A: Mario Caramanico <mario@markbass.it>

Oggetto: Re: - Problem with dev kit CY8CKIT-033A midi interface

<http://www.cypress.com>

<https://community.cypress.com/?et=watches.email.thread> Cypress Developer Community

Problem with dev kit CY8CKIT-033A midi interface

reply from EktaN_26 <https://community.cypress.com/people/EktaN_26?et=watches.email.thread> in PSoC 3 - View the full discussion <https://community.cypress.com/message/211043?et=watches.email.thread#211043>

0 Likes
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hello Mario,

There are several iOS updates after this thread was created. Can you please confirm if you are still facing this issue with the recent updates?

Best Regards

Ekta

0 Likes