Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1

Diako
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

 

Hi I'm connecting the following pressure sensor to my psoc using my psoc 5lp . I watched couple of tutorials on how to interface a pressure sensor and have looked at the ADC example on psoc website. My code is very similiar to the person on the youtube link below.  I also have watched the following analog sensor for the arduino code but its not working. similiar psoc posts also  couldn't help me solve the problem. The pressure is from alibaba, I have used the formula used by arduino community. 

 

Diako_0-1633654326819.png

 

 

Diako_0-1633653781019.png

 
 

 

 

https://www.youtube.com/watch?v=IqHeLsDwxVY&ab_channel=AngelaSodemann

https://youtu.be/UrqPxwsPWGk - anlog pressure sensor in arduino 

https://community.cypress.com/t5/PSoC-5-3-1-MCU/Bourns-analog-pressure-transducer/m-p/127862

 

 

 

0 Likes
1 Solution
EvPa_264126
Level 7
500 replies posted 250 replies posted 100 likes received
Level 7

 

This problem has been solved many times, so there shouldn't be any serious problems.
Check a few points:
1. Create / use a simple project with ADC DElSig with 10 bit resolution without using float.
- make sure that the measurement is working and is in the range> 0 <1000 bit.
2. The sensor signal should vary from 0.5V to 5V / 3.3V (check with a tester) аnd must be connected to the ADC input.
The archive of your project and the name / Datasheet of the sensor will help a lot
- it is always easier to continue what you started than to guess.
Evgeniy

View solution in original post

0 Likes
6 Replies
Vasanth
Moderator
Moderator First question asked 1000 replies posted 750 replies posted
Moderator

Hi,

Could you please share the exact code you have used and adc settings. Could you elaborate your observations too ?

Best Regards,
Vasanth

0 Likes
Diako
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

I was wondering if you know any psoc5 tutor that could help me with my project?

0 Likes
Diako
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

Hi Vasanth,

The maximum pressure for my pressure sensor is 0.8Mpa. I wanted to read it in PSI or pressure bar becuase megapascal is too small. I therefore converted 0.8 Mpa to PSI which is 116. I'm using a 10 bit ADC , therefore the maximum readable number should technically be 921.4 and the lowest number 102.4 but when I blow on it nothing happens. 

Diako_0-1633915227993.png

Diako_0-1633916281754.png

 

 

0 Likes
EvPa_264126
Level 7
500 replies posted 250 replies posted 100 likes received
Level 7

Did you run the ADC before polling? (see example codes for ADC DelSig)

ADC_DelSig_1_Start();
ADC_DelSig_1_StartConvert();

0 Likes
Diako
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

yes but that doesn't fix the problem. The LED keep flashing faster if I use the pressure as vaccum but that reading doesn't update in the LED. 

Diako_0-1633997922571.png

 

0 Likes
EvPa_264126
Level 7
500 replies posted 250 replies posted 100 likes received
Level 7

 

This problem has been solved many times, so there shouldn't be any serious problems.
Check a few points:
1. Create / use a simple project with ADC DElSig with 10 bit resolution without using float.
- make sure that the measurement is working and is in the range> 0 <1000 bit.
2. The sensor signal should vary from 0.5V to 5V / 3.3V (check with a tester) аnd must be connected to the ADC input.
The archive of your project and the name / Datasheet of the sensor will help a lot
- it is always easier to continue what you started than to guess.
Evgeniy

0 Likes