Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Anonymous
Not applicable

   i am trying to program CY8CKIT-050 through monoprog3 with psocprogrammer3.26 version,i got error                 

                                                               | FAILED! PSoC device is not acquired! Check connection of the chip to the programmer

                                                              |

Please, check the following items:

                                                              |  - the connection between the programmer and the PSoC;

                                                              |  - the correct programming protocol is selected;

                                                              |  - the correct connector option is selected.

program failed while power LED blinking.

7 Replies
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

I was successful when I powered the board with the miniprog3. Check the power settings (jumpers) of the -050 and configure the programmer accordingly. There have been some errors concerning USB cable too long.

Bob

0 Likes
Anonymous
Not applicable

i set jumpers on j10 1 & 2 shorted and j11 open

0 Likes
Anonymous
Not applicable

while programming power led blinking on miniprog3

0 Likes

Verify that your chip is a PSoC 5 LP. The older version without "LP" is not supported any more.

Bob

0 Likes

please check the USB cable too

0 Likes

If you are shorting J10's 1&2 pins, then short J11's 1 & 2 too

0 Likes
WaMa_286156
Level 5
Level 5
First comment on blog 100 replies posted 50 replies posted

If you are using a Windows VM under VMWare, please be aware that the latest version of VMWare has broken the MiniProg3.

Your best chance to get things working it so buy a CY8CKit-059 and break off the small board, add plug and cable, and make it a debugger.  It will work under VMWare.

  The problem is that the Miniprog3 comes up as something else, has to be programmed by the Cypress Driver, and then it turns into a MiniProg 3.  That sequence of events drives VMWare nuts, and it generally fails.  I *have* had it to work if you are willing to wait 20 to 60 seconds for it to finally be recognized.

0 Likes