Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
user_3568726
Level 2
Level 2
First like given

I have a CY8CKIT-059 PSOC5LP Prototyping kit and a PSOC CY8C58LP Family Porcessor Module(CY8C5868AXI-LP035), the CY8CKIT-059 PSOC5LP Prototyping kit can work well, now I want to use the Kitprog to program the  Porcessor Module with SWD, so I connect  Prog kit SWDIO/SWCLK/RST/GND/VTARGET  to Porcessor Module p1_0/p1_1/XRES/GND/VDD,  the PSOC creator shows that no devices detected, and computer shows below, what should I do? thanks so much.

3.jpg1.jpg2.jpg

0 Likes
1 Solution
user_3568726
Level 2
Level 2
First like given

finally I bought a miniprog3 and can program the board successfully.

View solution in original post

0 Likes
6 Replies
LinglingG_46
Moderator
Moderator
Moderator
500 solutions authored 1000 replies posted 10 questions asked

Did you disconnect the KitProg from the Kit-059?

0 Likes

YES, I just use the kitporg to program the Porcessor Module(CY8C5868AXI-LP035)

0 Likes

1.jpg

the documents say PSOC5 is configured for 4-wire JTAG mode by default, is that means it can be only programed by JTAG unlsess changed DPS setting?

0 Likes

Could you open the programmer to check whether the Kitprog can program?

0 Likes

Just a few notes about using Kitprog...

Kitprog SWD wire connections should be as short as possible.  5cm length works well.  Greaterthan 10cm causes signal integrity issues.

Also, make sure Kitprog green LED is not flashing slowly.  If it is, Kitprog is in bootloader mode.  A rapidly flashing green LED indicates it's trying to communicate with target device.  You want to see a rapidly flashing green LED.

As Lingling mentioned, try Programmer 3.28.  It provides better detail of SWD faults.  This will help debug what's going on.

I'm not familiar with the 5LP module, but, is it plugged into another pcb?  Kitprog/USB might not have enough +5V current to power up all the circuitry.  Try only connecting Kitprog to the 5LP module while separated from other circuitry.

Lastly, can the 5LP module be powered from SWD port?  Maybe there's a diode in the path preventing this.  Or, maybe there's an option jumper on the module to support SWD powering.

Bill

0 Likes
user_3568726
Level 2
Level 2
First like given

finally I bought a miniprog3 and can program the board successfully.

0 Likes