Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

Anonymous
Not applicable

Hi all.

   

Hopefully somebody can assist me with a problem we are having with receiving data from a CC1120 from TI.

   

We use a PSOC5  with a CC1120 from Texas Instruments. We managed to communicate (send data) with the CC1120 via SPI but cant read the data back. Although when we look at the received data on a datalogger we can clearly see that the data coming back from the CC1120 on the MISO line is correct. Please see attached screen shot from the oscilloscope. The data back is correct and should read 0F but in the software we read back 00. Please refer to line 178 in the Spi-Rf.c file.

When in debug mode the SPI module in not available as a component to see all the SPI registers.

   

Kind Regards

   

 

   

Matt

0 Likes
3 Replies
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Your handling of the SPI interface is a bit uncommon and I didn't find any extraordinaryties in the TI datasheet.

   

You control the timing and the status of the component with your register hardware which could be handled by the component itself.

   

Your MISO pin is resistive pull-down, is that needed?

   

I would suggest to

   

Open the connection between MISO pin and loop SPI MOSI to MISO.

   

Verify that you get every byte you send back into Rx, then modify the circuit to fit for the CC1120

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Hi Bob.

   

Thanks for the reply. The CC1120 have a very distinct way the SPI Select have to be done, The information is in the CC1101 user manual.

   

When you route the SPI MOSI line to the MISO line internal in the PSOC5 the SPI works. If you connect the to pins on the outside the SPI communications doesn't work.

   

We have resolved the problem though and for other people that might read this, the input buffer in the input (MISO) pin was not enabled. As soon as we enabled the buffer the SPI communication worked.

   

Regards

   

Matt

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Congratulations, Matt!

   

 

   

Bob

0 Likes