Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

Anonymous
Not applicable

 hi

   

I have a code when I compile it in debug mode it works without   any error but when I compile it to release mode the Fx3 crashes and didn't respond to commands that I send from computure  

   

what's wrong !!!!!!

   
        
0 Likes
3 Replies
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

In C-Language there might be a common fault when optimizing, which exactly is what the "Relese" settings are good for.

   

Have a look into this C-manual concerning "volatile"

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Hi bob 

   

 

   

I need  solution to reduce Fx3 latency

   

 

   

now  I have in interrupt pin <pin21> when it  set FX3 enter in interrupt routine and  disable the system

   

 

   

in short time no more than 850 ns  but now it takes  12 us !!!! 

   

 

   

 the interruption call back function is below   

   

 

   

 

   

 void CyFxGpioIntrCb (

   

        uint8_t gpioId /* Indicates the pin that triggered the interrupt */

   

        )

   

{

   

    CyBool_t gpioValue = CyFalse;

   

    CyU3PReturnStatus_t apiRetStatus = CY_U3P_SUCCESS;

   

    uint8_t data;

   

    apiRetStatus = CyU3PGpioSetValue (19, CyFalse);

   

 

   

    

   

}

0 Likes
Anonymous
Not applicable

 Hi,

   

Are you using Cypress USB device ? If yes, can you post here to get answers quickly ?

   

http://www.cypress.com/?app=forum&id=167&rID=42097

0 Likes