Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

Anonymous
Not applicable

Hello,

   

 

   

Questions: 

   

- What could cause the PSOC5 to heat up and cause the 3.3v bus to modulate a square wave?

   

- Should I power the PSOC5 from whatever voltage Vdda has running to it?

   

 

   

Background:

   

I'm working on a custom board that uses a PSOC5 68 pin package. The design has the PSOC5 running of 3.3V, Vdda at 5v and most of the other Vddio pins are set to 3,3v. If I power the PSOC5 from the miniprog, it shows up in psoc creator and there is no smoke. If I then plug my benchtop power supply in and then reconnect the miniprog, the psoc doesn't shows up. If I then disconnect the benchtop supply and hook up the miniprog like in the first case, the psoc never shows up. When I solder up just the power supply part of my circuit, the signal looks good with no ripple. The rise time is about 0.055V/us. 

   

To continue with the oddness, if I power a complete board (power circuit + psoc5) from the bench, there is a square wave on my 3.3v lines and the psoc5 gets to hot to touch. 

   

I'm running out of boards to solder up so I thought I'd get a few opinion on this before burning more chips up.

0 Likes
1 Solution
HeLi_263931
Level 8
Level 8
100 likes received 50 likes received 25 likes received

Glad you got it working!

   

It sounds as if the manual soldering left some of the ground pins (or maybe some power pins too) unconnected which led to some uncontrollable currents through the PSoC.

View solution in original post

0 Likes
14 Replies
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Vdda must be <= Vdd

   

 

   

Bob

0 Likes
HeLi_263931
Level 8
Level 8
100 likes received 50 likes received 25 likes received

Huh? I thought the rule was that Vdda must be the largest volatge in the system, so Vdda>=Vdd.

   

Question: how is your project configured in Creator? Are the voltages configured properly?

   

When you power via your bench supply, what are the voltages? When you do with Miniprog only, what are the voltages? They should be the same. Also, does your Miniprog try to supply the PSoC even when its powered by the bench supply?

   

The scenario with the square wave seem to indicate a failure in your PCB.

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Vdda must be >= Vddio, but both may not exceed the supply voltage Vddd

   

Datasheet here http://www.cypress.com/file/45906/download

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Bob -

   

 

   

I have to agree with HLI on vdda. On page 62 it says:

   

 

   

2 Vdda must be greater than or equal to all other power supplies (Vddd, Vddio’s) in PSoC 5.

   

 

   

Do you know some other rule i have missed?

   

 

   

Ed

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Yes, I have to admit to be wrong!

   

Have a look at page 26 of above manual and check if you did follow the notes for using the "internally regulated mode".

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Thank you for looking into this.

   

I haven't downloaded code to the PSOC during any of my tests. Should I program the device before apply benchtop power?

   

The supply is set to 9v which run through my 3.3v and 5v regulators. Without the psoc soldered in, it produces a clean dc voltage at those two levels. With the miniprog set to either 3.3v or 5v before ever testing it with the supply, the chip shows up in Creator. After applying power from the supply and setting the miniprog to externally powered, the PSOC5 never shows up. 

   

I double checked the notes on internally regulated mode and believe I have everything wired that way.

   

 

   

Additional info:

   

The chip consistently warms up or blows out in the quadrant near pin 1 and pin 68 if that helps. I don't know what system is routed through there.

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

There is no use programming the chip, it will not prevent it from blowing up when there is something darn wrong.

   

Think as: There is an error and how to discover it. It has to do with powering the chip, probably a short on the 3.3V (causing the square wave). Check all tabs (without the chip) with a scope, check for a 3.3 - 5V short.

   

 

   

Bob

0 Likes
HeLi_263931
Level 8
Level 8
100 likes received 50 likes received 25 likes received

Can you post your schematic (as its actually on the PCB) so we can have a look?

0 Likes
Anonymous
Not applicable

I haven't made any progress since last checking in. I have a psoc on board that registers with the "select debug target". It doesn't have any of the regulator circuitry.

   

How sensitive is the PSOC to rising voltages? Like when the system is powered from the benchtop, could the voltage rise to quickly?

   

 

   

HLI: Is the attached image what you where asking for?

   

The attached image is how the chip is laid out on the board. Yellow is 3.3v, Red is 5v, Green is ground. The lighter rust red are traces on the other side. The SWD connector isn't shown but I'm able to pull the PSOC up in the "Select Debug Target" window.

   

Thanks,

   

R04

0 Likes
Anonymous
Not applicable

What chip?

   

 

   

What does "actual pin 1" mean?

   

 

   

Do you have matching schematic?

   

 

   

QFN?  is pad grounded?  I've, personally, not found room for vias inside the perimeter. Are you sure?

   

 

   

Ed

0 Likes
Anonymous
Not applicable

CY8C5268LTI-LP030

   

The silkscreen indicator was put on the wrong corner of the pad. so I marked "actual pin 1" because that is where pin one really is.

   

It is QFN. From what I could find in the datasheet, I left the pad floating. 

   

 I drilled a hole through the center pad before building the latest board so I could hook a meter to it. Just before leaving work yesterday I was able to see the PSOC using the MiniProg as the power source and connecting the 5v and 3.3 systesm of the chip, to run the chip off the miniprog 3.3v.

   

I'll meter all the vias and center pads to see if anything was shorted when it was soldered together. 

0 Likes
HeLi_263931
Level 8
Level 8
100 likes received 50 likes received 25 likes received

Looking at the schematic (the second file), assuming its what the PCB really does:

   
        
  • pin 43 (Vssa) is not connected anywhere
  •     
  • pin 25 (Vssd) is not connected anywhere
  •     
  • pin 45 (Vssd) is connected to capacitors, but not to anything else (common ground)
  •    
   

All ground pins must be connected together and to ground! Otherwise you risk having ground currents inside of your device, especially with some capacitors connected to ground pins that are not connected to system ground.

   

Most probably when powering from 5V you have cross-currents in your ground connections (because you have two different regulators for them) which run inside of the PSoC.

0 Likes
Anonymous
Not applicable

Ahh the schematic was messed up when I tried to update it in a hurry.

   

 

   

I was able to solder everything using the stencil that arrived and .. it works. The board can be powered from the bench top without smoking. 

   

 

   

Solution:

   

Use a stencil and reflow the QFN and don't try to solder it by hand. 

   

 

   

Thank you guys for double checking my layout, I appreciate it. 

0 Likes
HeLi_263931
Level 8
Level 8
100 likes received 50 likes received 25 likes received

Glad you got it working!

   

It sounds as if the manual soldering left some of the ground pins (or maybe some power pins too) unconnected which led to some uncontrollable currents through the PSoC.

0 Likes