Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

GoKe_1237761
Level 2
Level 2

The device is a CY8C29466-24PXI, PSoC 1, Designeer 4.4 .

   

I have this working with a CY8C27443-24PXI but I can not seem to get to work with this processor.

   

I want to write 64 bytes to 0x7f80, I have a ram buffer of 64 bytes called "rx_buffer" It also seems to take 2 or 3 seconds to come back from the write_eeprom code.

   

Ant help would be wonderful.

   

Thanks

   

Gord

0 Likes
3 Replies
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Welcome in the forum, Gord.

   

The processor of the Cy8C27xx and the Cy8C29xx are quite the same, only the 27443 has got 16K flash and only 256 bytes of sram. Hence there cannot be a large code difference.

   

The PSoC Designer is a bit outdated, I would suggest you to update to current version which is 5.4

   

Check if you set the Firstblock to 510.

   

Check if you modified the flash security to allow writes to the required blocks

   

 

   

Bob

0 Likes

Hi Bob

   

Firstblock is set to 510 and the flash security is set to U for the last 2 blocks but I cannot get it to write.

   

Would you have a assembly code snippet to share?

   

Thanks

   

Gord

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Only code snippets are in datasheet for eeprom. Check your stack and stack setting.

   

Switch over to PSoC4, more modern, cheaper, debug capabilities, but no DIL-package. Check the prototyping kit CY8CKIT-043.

   

 

   

Bob

0 Likes