Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 5, 3 & 1 Forum Discussions

Not applicable

This is a continuation of this thread: http://www.cypros.org/?app=forum&id=0&rID=89110  I was able to find an alternative means to work around the problem, but I have again run into this issue.  I've tried all the suggestions in the thread, and nothing has worked.  There seems to be confusion that I am getting faulty values... that isn't the issue.  The issue is when using the ADC to read values after calling ADC_SelectConfiguration(), no values are returned *at all*.  It actually gets caught up in the ADC_IsEndConversion(uint8 retMode) function in the ADC.c file.  The ADC_DEC_SR_REG register never gets set to 1, and so, the function blocks until I quit the program.  It works fine if I never call SelectConfiguration.


Can anyone help me figure out what's going on?  I haven't been able to find this issue anywhere else on the forum.  

3 Replies
Level 9
100 sign-ins 5 likes given 1000 replies posted
Level 9

You might consider filing a CASE on this, and post your project when


you file the case -








To create a technical case at Cypress -








“Technical Support”


“Create a Case”




You have to be registered on Cypress web site first.




Regards, Dana.

Level 8
100 likes received 50 likes received 25 likes received
Level 8

Did you start / execute a conversion after selecting a new configuration?

Level 1
5 sign-ins First reply posted First question asked
Level 1

Many delta sigma functions are interrupt based and can create problem with other interrupt (ex.: use theses functions inside an interrupt). Is it your case?