Announcements

Equip yourself to optimize PSoc4 MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

saurabh
Level 3
Level 3
50 sign-ins 25 sign-ins 10 replies posted

Hello,

I am currently working on CY8C4124ZI-S433 microcontroller. According to the datasheet the pin 4[0] and 4[1] support scb_uart[0] but when I try to assign the pins as uart using the psoc creator software, the software is restricting the uart pin assignment to the mentioned pins and rerouting the pins to P0[4] and P0[5] (scb_uart[1] as per datasheet). Attached is the screnshot of the datasheet instructing availability of scb_uart[0]. Any suggestion on the would be appreciated.

0 Likes
1 Solution
Hari
Moderator
Moderator
Moderator
750 replies posted 500 replies posted 250 solutions authored

Hi @saurabh 

 

The selected MPN, CY8C4124AZI-S433, only has two SCB blocks - SCB1 and SCB2. SCB0 is only valid in some MPNs in the family and therefore, it is not supported by CY8C4124AZI-S433. Please refer the snippet from the ordering information section of the datasheet - 

Hari_0-1641915406016.png

 

 

Best regards, 
Hari

View solution in original post

0 Likes
1 Reply
Hari
Moderator
Moderator
Moderator
750 replies posted 500 replies posted 250 solutions authored

Hi @saurabh 

 

The selected MPN, CY8C4124AZI-S433, only has two SCB blocks - SCB1 and SCB2. SCB0 is only valid in some MPNs in the family and therefore, it is not supported by CY8C4124AZI-S433. Please refer the snippet from the ordering information section of the datasheet - 

Hari_0-1641915406016.png

 

 

Best regards, 
Hari

0 Likes