Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
Not applicable

Hi,  I am new to psoc4 and for the most part I have been very impressed with the flow!  I am finally trying to implement my application with a bootloader for the final product and am having problems with the uart bootloader.  


I have stepped back and tried to get things running on the pioneer board with the bootloader examples.  I was able to get the i2c bootloader example working.  I modified the project to support the uart bootloader and it is not working.  I get the following error: "The bootloader reported error 'Packet length invalid: the packet's length does not conform to the required packet format"


I ahve double and tripled checked my setting and dropped the baudrate just be sure it was not a timing issue, but keep getting the same error.  Based upon error, it sounds like the packet size generated in the bootloadable project may be the issue?  I don't see any settings for this.


Any ideas?  As always, I'm time crunched to get this working.   I have attached my bootloader and bootloadable projects.



1 Reply
Not applicable

I opened a case and got a very fast response from support.   Here is the solution for anyone else who runs into the same issue:


"Because the host can send packets as large as 64 bytes, you'll need to increase the UART Rx and Tx buffers to 64 bytes. This can be changed from the "UART Advanced" tab in the UART's component configuration."