Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

tgf
Level 1
Level 1
First reply posted First question asked Welcome!

hello,

I set the pin P0.7 of CY8C4245AXI-483 to high. but it turns to high 1s after power-on.Power supply and reset are completed within 3ms.So what is the cause of this one-second delay?

0 Likes
1 Solution

Hello.

I suspect you are calling CyDelay(1000) for the LED's (since they show a 1 second delay in the logic trace capture screen).  Followed by setting SPI_SS.

Well, CyDelay() is a blocking function.  So, nothing else runs until after CyDelay() has completed (it's a software timing  loop delay).

Can you post your project bundle?

View solution in original post

0 Likes
3 Replies
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi,

Are you using a custom psoc board or any of the development kits ? How are you setting the pins ? Did you try debugging the code ? Does it happen 1s after the firmware sets the pin ?

Best Regards,
Vasanth

0 Likes
tgf
Level 1
Level 1
First reply posted First question asked Welcome!

I used in ourself design。Settings are shown in the picture。All the other outputs are normal, except for this one with a one-second delay。Is it possible for it's the Multiplexing pins of wakeup?12.png

11.png

0 Likes

Hello.

I suspect you are calling CyDelay(1000) for the LED's (since they show a 1 second delay in the logic trace capture screen).  Followed by setting SPI_SS.

Well, CyDelay() is a blocking function.  So, nothing else runs until after CyDelay() has completed (it's a software timing  loop delay).

Can you post your project bundle?

0 Likes