Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
SoiltechLuke
Level 1
Level 1
First question asked Welcome!

Set up new board with a fresh psoc4000s, tried to program it with an existing program from psoc creator, and got a failed programming notification. Dug into the problem and it is due to a checksum fail after the  "protect" step. Only thing is that I'm still in development and have never set up flash protection... so why am I getting a protected block? have tried multiple erases, clean and build, reprogramming etc...

Set up a second board and everything programs just fine; and as I would expect, it says that it has no protected blocks...

Already checked out https://community.infineon.com/t5/PSoC-5-3-1/Checksum-Failed/td-p/210189 but it's not a perfect fit as my program doesn't modify anything, and my question is more about clearing the protection on a single device

0 Likes
1 Reply
ncbs
Moderator
Moderator
Moderator
500 replies posted 50 likes received 250 sign-ins

Hi @SoiltechLuke,

Fresh devices should ideally not have any protected blocks, and your observation is surprising. The factory default setting is OPEN, and hence no protection would be enforced.  Can you verify the following points:

  1. Make sure none of the blocks are set to "W" [full protection mode] in the "flash security" tab.
    ncbs_0-1684911676975.png
  2. In the "system" tab, the chip protection needs to be set to "OPEN".

Regards,
@ncbs 

0 Likes