Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

suga_4501896
Level 1
5 replies posted 5 sign-ins 5 questions asked
Level 1

i am trying to run CE224599(I2C_SCB_Slave) program on cy8ckit-042-ble Pioneer kit using CY8C4248LQI-BL583 BLE Module. But when i check it on Bridge Control Panel it's showing me device not found. 

0 Likes
8 Replies
ncbs
Moderator
Moderator 50 likes received 250 sign-ins 250 replies posted
Moderator

Hi @suga_4501896 ,

  1. Is your kit connected to the PC being recognized? Are you able to see the kit being recognized in Device Manager > Ports (COM & LPT) ?
  2. Are you able to successfully program the kit and observe the green light turned on?
  3. In BCP: Are you able to see the kit in the "Connected I2C/SPI/RX8 Ports" list? Make sure that you have selected I2C as the protocol.

Regards,
Nikhil

0 Likes
suga_4501896
Level 1
5 replies posted 5 sign-ins 5 questions asked
Level 1

I am able to see kitprog in device manager ports.

I successfully program the kit and green led is also on.

I  am able to see kit in connected i2c/spi/rx8 select the i2c protocol and set the i2c speed.

But when i click on list it shows me "No Device Found".

0 Likes
ncbs
Moderator
Moderator 50 likes received 250 sign-ins 250 replies posted
Moderator

Hi @suga_4501896,

I tried the CE at my end too. And I could see the devices when "List" button was clicked. The code example uses 100kHz as the I2C speed. Can you confirm whether you have selected 100kHz as the I2C speed?

ncbs_0-1659509432603.png

It is only then the I2C communication successfully works. Once you set the proper speed, you will be able to see the devices connected as shown below:

ncbs_1-1659509757227.png

Regards,
Nikhil

 

0 Likes
suga_4501896
Level 1
5 replies posted 5 sign-ins 5 questions asked
Level 1

Hi Nikhil,

yes i confirm that i select the 100khz speed.

suga_4501896_0-1659511846757.png

when i click on list it shows 'No device found'

suga_4501896_1-1659511915383.png

 

here is what showing in 'device manager' port.

suga_4501896_2-1659512029895.png

 

0 Likes
ncbs
Moderator
Moderator 50 likes received 250 sign-ins 250 replies posted
Moderator

Hi @suga_4501896,

KitProg has been assigned COM3, as visible in the device manager, but BCP identifies them as separate connections. COM3 is usually used by Intel Active Management Technology. Could you please change the COM port number for KitProg to something other than 3?

Right click on KitProg and click Properties. Go to Port settings -> Advanced.

ncbs_0-1659593734266.png

Change the COM port number to something other than 3:

ncbs_1-1659593823171.png

 

Regards,
Nikhil

0 Likes
suga_4501896
Level 1
5 replies posted 5 sign-ins 5 questions asked
Level 1

Hii Nikhil,

I change the port number as you mentioned above but again getting same message 'device not found'.

I try 4-5 different COM Ports but facing same issue.

0 Likes
ncbs
Moderator
Moderator 50 likes received 250 sign-ins 250 replies posted
Moderator

Hi @suga_4501896 ,

Are you able to perform I2C transaction?

You may make use of our code examples, CE222306 and CE224599 (you have already used this), to achieve a I2C master-slave configuration. Please check if the slave is able to receive data being sent from master and vice versa. 

Regards,
Nikhil

0 Likes
suga_4501896
Level 1
5 replies posted 5 sign-ins 5 questions asked
Level 1

Hi Nikhil,

I use CE222306 but again facing same issue.

0 Likes