Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

electron
Level 1
First reply posted First question asked Welcome!
Level 1

I get this message when trying to compile code that is known to work.  I saw the other post similar to this.  This system would not permit me to reply to that post.   I have tried the update components command.  It upgraded the first time from 5.6 to 5.7 but will not upgrade to 5.8 - there is no choice to do this.  I have upgraded using the upgrade wizard tool and this did not help either.  Any ideas or assistance is greatly appreciated.

0 Likes
1 Solution
Alakananda_BG
Moderator
Moderator 250 sign-ins 250 replies posted 100 solutions authored
Moderator

Hi @electron 

The component version 5.81 is only available in higher versions of the PSoC Creator Software.

For example, in PSoC Creator 4.4 you can observe that the component version supported is till 6.10 for cy_boot component as shown below:

Alakananda_BG_0-1658732759063.png

Please install PSoC Creator 4.3 or higher to use v5.81 component of cy_boot component.

Unfortunately the latest version of the components are available only in the latest version of PSoC Creator and the same is not backward compatible.

Regards,

Alakananda

View solution in original post

0 Likes
6 Replies
Alakananda_BG
Moderator
Moderator 250 sign-ins 250 replies posted 100 solutions authored
Moderator

Hi,

Please check if you have a folder named "cy_boot_v5_80" in the following path: "C:\Users\<username>\Documents\PSoC Creator\4.4\Downloads ( 4.4).cylib".

Open the project "Downloads ( 4.4).cyprj" in PSoC Creator. If you notice "cy_boot_v5_80" in the workspace explorer, then delete it and then go to Tools > Find new components and update cyboot.

If you don't notice "cy_boot_v5_80" in the workspace explorer, then directly go to Tools > Find new components and update cyboot.

Now close this project. And open your project and check if you are able to update successfully.

Regards,

Alakananda
0 Likes
electron
Level 1
First reply posted First question asked Welcome!
Level 1

Thank you so much for your detail !!

My folder path looks like this:
c:\Users\dan\Documents\PSoC Creator\4.2\Downloads ( 4.2).cylib\
I was able to open the project:  Downloads (4.2).cyprj

I did not find cy_boot_v5_80 in the workspace explorer

When I try right click the project and click on Update Components I get a dialog box that says Component Update Tool, Select a component to update and it shows only Downloads (4.2).  If I click next it says no components have been chosen for update.

When I try tools>Find new components - there is no place for me to click to update cyboot.  The drop-down list is "All" and cannot be changed.  The search box is empty and no components show up in the list.  The Install Checked Components box is grayed out.

 

0 Likes
Alakananda_BG
Moderator
Moderator 250 sign-ins 250 replies posted 100 solutions authored
Moderator

Hi @electron ,

Can you let us know the device which you are using?

Can you change your device to any other PSoC 4 device (maybe CY8C4248LQI-BL583) and check if you are able to get the latest cy_boot?

Regards,

Alakananda
0 Likes
electron
Level 1
First reply posted First question asked Welcome!
Level 1

I am using CY8C4248LQI-BL583.  I tried changing it to CY8C4248LQI-BL593 but this did not load the cy_boot_v5_80.  I put it back to the 583 part.  Then I tried running the component update tool and got this window:

electron_0-1658362693003.png

But after pressing next it went back to the default version 5.7 as it shows 5.80 as (unknown).

0 Likes
Alakananda_BG
Moderator
Moderator 250 sign-ins 250 replies posted 100 solutions authored
Moderator

Hi @electron 

The component version 5.81 is only available in higher versions of the PSoC Creator Software.

For example, in PSoC Creator 4.4 you can observe that the component version supported is till 6.10 for cy_boot component as shown below:

Alakananda_BG_0-1658732759063.png

Please install PSoC Creator 4.3 or higher to use v5.81 component of cy_boot component.

Unfortunately the latest version of the components are available only in the latest version of PSoC Creator and the same is not backward compatible.

Regards,

Alakananda
0 Likes
electron
Level 1
First reply posted First question asked Welcome!
Level 1

The reason I had the 4.2 version installed is because that is what I used in the past which did not have this issue.  That said, and no other solution, I uninstalled version 4.2 and installed version 4.4 - and then updated all the components.  Now it works, so problem is solved.  I think my issue came from the fact that it used to work in the earlier version and now something changed.

Thank you very much for your help and support on this issue!!

0 Likes