Showing results for 
Search instead for 
Did you mean: 

PSoC™ 4

Not applicable

I'm using a PSOC CY8C4248AZI-L485 and trying to implement the USBUART but no matter what I do, I can't get it to recognize the device in Windows.


I started with the sample USBUART project, and made very few changes beyond stripping out some #ifdef code that wasn't executing, and adding a red and green status LED.  


The 4248 is running at 3.3V, and I'm self-powering it from an external source.  The 5V from the USB is applied to the VBUS, and I've tried all combinations of VBUS monitoring both on and off.  I've tried swapping D+/D- and it made no difference.  The D lines were initially passed through series resistors, but I've since eliminated them.  There is no other filtering or static protection on the current prototype.


Whenever I plug it in, I get an error message in Windows (10) that the Device Descriptor Request Failed.  It usually recognizes that I did plug something in to the USB port, but I will add that especially early on during the dev cycle, it wouldn't always attempt to load drivers.  Somewhere along the way it's gotten more responsive to that function.


I installed the .inf file that is generated as part of the projct (I had to boot into the recovery mode to allow Windows to install an unsigned driver).  That made no difference.


I had also installed some generic Cypress USB driver that I found during my travels, but that hasn't seemed to make any difference either.


Attached is the project as it stands today, as well as a screenshot of the error message that I'm seeing in Device Manager.  


I'm new to the USB device development, so I'm not really sure what else might be useful to others to troubleshoot.  It seems like I'm just one little step away from getting this going though.



1 Reply
Not applicable

I did a little more digging tonight on this, and the D- (pin 35) is floating up around 3.8V, and when I first plug in the USB cable, I see that line toggling low with data for about a second.  The D+ line (pin 34) stays at ground potential the whole time.


I swapped the D+/D- lines and the scope shows more like what I'd expect.  Both lines toggle, and they're opposite of each other.



After a couple of reboots on the PSOC, I finally noticed that I did in fact have a USB->Serial port enumerating (COM5).  The only odd thing is that I still have a secondary device that is showing up with the same Device Descriptor Request Failed under USB Controllers.