Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

JaLi_1091341
Level 1
Level 1
First question asked First reply posted Welcome!

I am experimenting with UART bootloader for pSoc4 starting with the code from AN68272.    I unpacked the source code,  built all the projects in the workspace w/o errors.

Since I want to use a custom pcb based on the CY8C4247 instead of the CY8C4245,   I went to each of the three projects (UART_Bootloader,  Bootloadable1/2) and used the Device Selector to change the project processor type from CY8C4245 to CY8C4247AZI-M475.     Then cleaned,rebuilt the Bootloader w/o issue but when I try to clean/built either Bootloadable1 or Bootloadable2,   I now get an error ...

The selected device for the Bootloader and Bootloadable projects must match, but don't. Bootloader is targeting 'CY8C4245AXI-483' and Bootloadable is targeting 'CY8C4247AZI-M475'.

This happens during the fit stage of the build.

My Bootloader project says its for an CY8C4247AZI-M475 but somehow the build for bootloadable1/2 thinks its for the prior processor type.     I'm not seeing where in the build configuration I can change/update this.

Thanks

Jim

0 Likes
1 Solution
BiBi_1928986
Level 7
Level 7
500 replies posted 250 replies posted 250 sign-ins

Hello.

Sounds like the bootloadable app's are referencing the old bootloader hex/elf files.  Need to up date this.

Do the following:

On the schematic for each bootloadable, double-click on the component Bootloadable.

In the component window that opens, click on tab "Dependencies".

In the line "Bootloader HEX file", use the "Browse..." button to find the file location of the new Bootloader that uses CY8C4247.

The .elf line will automatically be filled in.

Now, click OKAY or Apply, close that window.

Re-build each bootloadable application.

Should be good now.

BTW, the Getting Started guide for KIT-049 is very good at explaining this.

Good luck with your project.

View solution in original post

0 Likes
2 Replies
BiBi_1928986
Level 7
Level 7
500 replies posted 250 replies posted 250 sign-ins

Hello.

Sounds like the bootloadable app's are referencing the old bootloader hex/elf files.  Need to up date this.

Do the following:

On the schematic for each bootloadable, double-click on the component Bootloadable.

In the component window that opens, click on tab "Dependencies".

In the line "Bootloader HEX file", use the "Browse..." button to find the file location of the new Bootloader that uses CY8C4247.

The .elf line will automatically be filled in.

Now, click OKAY or Apply, close that window.

Re-build each bootloadable application.

Should be good now.

BTW, the Getting Started guide for KIT-049 is very good at explaining this.

Good luck with your project.

0 Likes

Perfect ...thanks.    Building is fine now.

Jim

0 Likes