cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ 4

wangyuanfan
New Contributor II

I’m using example code CapSense_with_Breathing_LED01 and SenseTuner to display the capacitance.

But I’m enable to connect with device CY8CKIT-149.There is error message “There was an error reading data from the device”.

Please tell me how to fixed it.

0 Likes
1 Solution
ncbs
Moderator
Moderator

Hi @wangyuanfan,

The following picture shows the EZI2C parameters from the Top Design schematic.

ncbs_0-1638344770384.png

Now, after the project has been built and programmed onto the kit, right-click on the capsense component and select Launch Tuner. Ensure that the parameters are properly set here.

ncbs_1-1638345009157.png

 

After setting the parameters, click OK. Then click connect. You should positively see your device getting connected to Sense Tuner app. Then click Start.

 

Using the project shared by you [https://community.infineon.com/t5/PSoC-4/There-was-an-error-reading-data-from-the-device/td-p/326407], I am able to connect to the device and see the response from the capsense system in Sense Tuner app.

 

Best regards,
Nikhil

 

 

View solution in original post

0 Likes
8 Replies
ncbs
Moderator
Moderator

Hi @wangyuanfan ,

1. You may have opened Tuner from a different project. This may be the likely situation. Open the Sense Tuner app from the same project which was programmed onto the device. 

2. The configuration of the communication protocol being used (UART or EZI2C) may be wrongly selected.

Best regards,
Nikhil

0 Likes
wangyuanfan
New Contributor II

1. I deleted all the projects and created a new one with Example Code CapSense_with_Breathing_LED01.

Then opened the SenseTuner app from the same project(There is only one project), but it still didn't work.

2. How to check it?

0 Likes
ncbs
Moderator
Moderator

Hi @wangyuanfan,

These are the EZI2C configuration parameters. Follow the same in the Sense Tuner app.

EZI2C configuration:
- Data Rate : 400 kbps
- Number of addresses: 1
- Primary slave address: 0x08
- Sub-address size: 16 bit

 

Ensure that the speed is selected to 400kHz.

 

Best regards,
Nikhil

0 Likes
wangyuanfan
New Contributor II

I made sure that is same as the configuration you shared.

0 Likes
ncbs
Moderator
Moderator

Hi @wangyuanfan,

The following picture shows the EZI2C parameters from the Top Design schematic.

ncbs_0-1638344770384.png

Now, after the project has been built and programmed onto the kit, right-click on the capsense component and select Launch Tuner. Ensure that the parameters are properly set here.

ncbs_1-1638345009157.png

 

After setting the parameters, click OK. Then click connect. You should positively see your device getting connected to Sense Tuner app. Then click Start.

 

Using the project shared by you [https://community.infineon.com/t5/PSoC-4/There-was-an-error-reading-data-from-the-device/td-p/326407], I am able to connect to the device and see the response from the capsense system in Sense Tuner app.

 

Best regards,
Nikhil

 

 

0 Likes
wangyuanfan
New Contributor II

It worked exactly!!!

Thank you so much!!!!!

0 Likes
wangyuanfan
New Contributor II

I changed I2C address from 0 to 8.

0 Likes
ncbs
Moderator
Moderator

Hi @wangyuanfan ,

Glad to know it is working now 🙂

Best regards,
Nikhil

0 Likes