There is an error associated with this component

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
tiphc_1376351
Level 3
Level 3
First like received

In my PSoC Creator 4.2 project the BLE component has a notice which states "There is an error associated with this component."  The notice list shows that the program can't find a file named BLE_v3_53.dll.  How do I acquire this missing dll?  Uninstalling and reinstalling PSoC Creator did not work.

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Hello Timothy,

Maybe the .dll file went missing due to some reason. But you can do the following:

Navigate to C:\Users\<user_name>\Documents\PSoC Creator\<psoc_creator_version>\Downloads ( 4.2).cylib

Here you will find a folder called "BLE_v3_53". Please delete it and then perform update components in your PSoC Creator project. The files will be generated again and this time your DLL should be generated successfully.

Regards,

Dheeraj

View solution in original post

0 Likes
2 Replies
tiphc_1376351
Level 3
Level 3
First like received

BLE version 3.53 is clearly defective.  The error went away when I downgraded back to BLE version 3.50.

0 Likes
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Hello Timothy,

Maybe the .dll file went missing due to some reason. But you can do the following:

Navigate to C:\Users\<user_name>\Documents\PSoC Creator\<psoc_creator_version>\Downloads ( 4.2).cylib

Here you will find a folder called "BLE_v3_53". Please delete it and then perform update components in your PSoC Creator project. The files will be generated again and this time your DLL should be generated successfully.

Regards,

Dheeraj

0 Likes