Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

baye_4029466
Level 1
5 replies posted First reply posted Welcome!
Level 1

Hi,

I'm connecting from a mobile android device to the PSOC4 BLE and having troubles (from time to time the connection process is fail) since I upgraded the BLE stack from version 3.54 to 3.65. I have tested it and the problem occurs since BLE stack version 3.62.

I have few questions: image_2020_07_14T13_20_14_959Z.png

1. As can be seen in the picture above, the connection is terminated after an unknown response from FEATURE_REQ. Is there something wrong with the LL_FEATURE_REQ?

2. Is there something I can do to overcome this problem?

3. I upgraded the BLE stack because of security breach (SweynTooth: Unleashing Mayhem over Bluetooth Low Energy https://asset-group.github.io/disclosures/sweyntooth/​) solved by the updated stack . what is the BLE stack version that solves this issue?

Thanks,

Barak.

SweynTooth: Unleashing Mayhem over Bluetooth Low Energy (https://asset-group.github.io/disclosures/sweyntooth/)
from The ASSET (Automated Systems SEcuriTy) Research Group at the Singapore University of Technology and Design

https://asset-group.github.io/

0 Likes
3 Replies
VenkataD_41
Moderator
Moderator 750 replies posted 500 replies posted 250 solutions authored
Moderator

Hi Barak,

1. Is this happening for your application only or for all applications that use BLE? You can use BLE_FindMe code example from PSoC Creator.

2. BLE stack v3.65 is the latest stack and we recommend you to use this only.

3. What is the Android device that you are using?

4. Can you please attach the project and mention the steps to reproduce the issue?

Thanks

Ganesh

0 Likes
baye_4029466
Level 1
5 replies posted First reply posted Welcome!
Level 1

Hi Ganesh,

After further investigation, we found out that the problem is probably on the specific Andorid BLE stack we use (we use customize device and not a mobile phone, so you cant test it on your side).

Thnaks,

Barak.

0 Likes
Yugandhar
Moderator
Moderator 1000 replies posted 5 likes given First comment on blog
Moderator

Problem might comes from your Andorid BLE stack, please check the configuration.

Thanks,

P Yugandhar.

0 Likes