Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4

secic_4090646
Level 1
Level 1

I built the BOARD which contains the attached wiring diagram

Schematic.JPG

If I connect only the CYBLE-022001-00 module to the programming connector

CN8, the component is programmed.

If I connect the whole circuit, the module is not programmed.

I ask if anyone can give me directions to find the problem.

Thanks

Sergio

0 Likes
1 Solution
GyanC_36
Employee
250 replies posted 100 replies posted 50 replies posted
Employee

Hi Sergio,

   Since the standalone module is programming without any issue and hence there should not be any problem related to Module side. Please check your external circuitry connections (  any soldering issue ) to resolve this problem.

You can also probe the SWD lines and analyze the waveform at different test points.

-Gyan

View solution in original post

2 Replies
GyanC_36
Employee
250 replies posted 100 replies posted 50 replies posted
Employee

Hello Sergio,

     Your schematic picture is not clearly visible. Could you please attach pdf file ?

-Gyan

0 Likes
GyanC_36
Employee
250 replies posted 100 replies posted 50 replies posted
Employee

Hi Sergio,

   Since the standalone module is programming without any issue and hence there should not be any problem related to Module side. Please check your external circuitry connections (  any soldering issue ) to resolve this problem.

You can also probe the SWD lines and analyze the waveform at different test points.

-Gyan