Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

dasprogrammer
Level 1
Level 1
First question asked Welcome!

Hello peeps, I have a query for the component PWM v3.30. This component of v3.30 is shown as available in the component library of one of my programs with CY8C4245PVI-482 but if I try to find the exact component for CY8C4A45AZI-483 it appears that the conventional TCPWM v2.10 is only available. I guess both the controllers are from the same PSOC4 Family, then why is this happening? 

PFA: Attaching documentation of both the components 

0 Likes
1 Solution
ncbs
Moderator
Moderator
Moderator
50 likes received 250 sign-ins 250 replies posted

Hi @dasprogrammer ,

TCPWM v2.10 uses the TCPWM blocks present in the PSoC, whereas PWM v3.30 offers you to use either UDBs or TCPWM blocks to realize PWM functionality. Devices that support UDB functionality offer the PWM v3.30 component.

Regards,
Nikhil

View solution in original post

0 Likes
1 Reply
ncbs
Moderator
Moderator
Moderator
50 likes received 250 sign-ins 250 replies posted

Hi @dasprogrammer ,

TCPWM v2.10 uses the TCPWM blocks present in the PSoC, whereas PWM v3.30 offers you to use either UDBs or TCPWM blocks to realize PWM functionality. Devices that support UDB functionality offer the PWM v3.30 component.

Regards,
Nikhil

0 Likes